summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/python/python3-hypothesis_6.14.0.bb
diff options
context:
space:
mode:
authorTim Orling <timothy.t.orling@intel.com>2021-06-13 14:17:34 -0700
committerTim Orling <timothy.t.orling@intel.com>2021-06-13 16:18:15 -0700
commit2e762b2c77c41b8453bdd009ec3faa233ad52d2b (patch)
treeb8e94bc5888d5ff89baaa48fa69f06cb62a38955 /meta/recipes-devtools/python/python3-hypothesis_6.14.0.bb
parente716149e64b94c23b40d63095754c64cfe02a17a (diff)
downloadopenembedded-core-contrib-2e762b2c77c41b8453bdd009ec3faa233ad52d2b.tar.gz
python3-hypothesis: upgrade 6.13.14 -> 6.14.0timo/recipe-upgrades-20210613
Add runtime dependency on: - python3-compression - python3-json - python3-statistics Upstream release notes: 6.14.0 - 2021-06-09 The explain phase now requires shrinking to be enabled, and will be automatically skipped for deadline-exceeded errors. https://hypothesis.readthedocs.io/en/latest/changes.html#v6-14-0 Signed-off-by: Tim Orling <timothy.t.orling@intel.com>
Diffstat (limited to 'meta/recipes-devtools/python/python3-hypothesis_6.14.0.bb')
-rw-r--r--meta/recipes-devtools/python/python3-hypothesis_6.14.0.bb22
1 files changed, 22 insertions, 0 deletions
diff --git a/meta/recipes-devtools/python/python3-hypothesis_6.14.0.bb b/meta/recipes-devtools/python/python3-hypothesis_6.14.0.bb
new file mode 100644
index 0000000000..89071b2a97
--- /dev/null
+++ b/meta/recipes-devtools/python/python3-hypothesis_6.14.0.bb
@@ -0,0 +1,22 @@
+SUMMARY = "A library for property-based testing"
+HOMEPAGE = "https://github.com/HypothesisWorks/hypothesis/tree/master/hypothesis-python"
+LICENSE = "MPL-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=4ee62c16ebd0f4f99d906f36b7de8c3c"
+
+PYPI_PACKAGE = "hypothesis"
+
+inherit pypi setuptools3
+
+SRC_URI[sha256sum] = "9bdee01ae260329b16117e9b0229a839b4a77747a985922653f595bd2a6a541a"
+
+RDEPENDS_${PN} += " \
+ python3-attrs \
+ python3-compression \
+ python3-core \
+ python3-json \
+ python3-sortedcontainers \
+ python3-statistics \
+ python3-unittest \
+ "
+
+BBCLASSEXTEND = "native nativesdk"