summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/python/python3-dbus_1.2.6.bb
diff options
context:
space:
mode:
authorDerek Straka <derek@asterius.io>2018-02-11 11:36:04 -0500
committerRichard Purdie <richard.purdie@linuxfoundation.org>2018-02-24 10:31:35 +0000
commita6e8e789413c8f953fca2ad0c2591dea0993ccd1 (patch)
treed9a3f097b0c2ef20a60aa267ea105539db38d75a /meta/recipes-devtools/python/python3-dbus_1.2.6.bb
parent1753025597a9053922155bb98511a33cab6057a7 (diff)
downloadopenembedded-core-contrib-a6e8e789413c8f953fca2ad0c2591dea0993ccd1.tar.gz
python3-dbus: update to version 1.2.6
License-Update: Checksum updated for added clarification to licenses in other directories and verified the license terms remain the same Signed-off-by: Derek Straka <derek@asterius.io> Signed-off-by: Ross Burton <ross.burton@intel.com>
Diffstat (limited to 'meta/recipes-devtools/python/python3-dbus_1.2.6.bb')
-rw-r--r--meta/recipes-devtools/python/python3-dbus_1.2.6.bb23
1 files changed, 23 insertions, 0 deletions
diff --git a/meta/recipes-devtools/python/python3-dbus_1.2.6.bb b/meta/recipes-devtools/python/python3-dbus_1.2.6.bb
new file mode 100644
index 0000000000..19cbae91a4
--- /dev/null
+++ b/meta/recipes-devtools/python/python3-dbus_1.2.6.bb
@@ -0,0 +1,23 @@
+SUMMARY = "Python bindings for the DBus inter-process communication system"
+SECTION = "devel/python"
+HOMEPAGE = "http://www.freedesktop.org/Software/dbus"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://COPYING;md5=b03240518994df6d8c974675675e5ca4"
+DEPENDS = "expat dbus dbus-glib virtual/libintl"
+
+SRC_URI = "http://dbus.freedesktop.org/releases/dbus-python/dbus-python-${PV}.tar.gz \
+"
+
+RSRC_URI[md5sum] = "1ce1ddf2582060f8f971652ea54cc17e"
+SRC_URI[sha256sum] = "32f29c17172cdb9cb61c68b1f1a71dfe7351506fc830869029c47449bd04faeb"
+S = "${WORKDIR}/dbus-python-${PV}"
+
+inherit distutils3-base autotools pkgconfig
+
+PACKAGECONFIG ?= ""
+PACKAGECONFIG[docs] = "--enable-html-docs,--disable-html-docs,python3-docutils-native"
+PACKAGECONFIG[api-docs] = "--enable-api-docs,--disable-api-docs,python3-docutils-native python3-epydoc-native"
+
+RDEPENDS_${PN} = "python3-io python3-logging python3-stringold python3-threading python3-xml"
+
+FILES_${PN}-dev += "${libdir}/pkgconfig"