aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/python/python3-dbus_1.2.4.bb
diff options
context:
space:
mode:
authorAlexander Kanavin <alexander.kanavin@linux.intel.com>2016-06-02 12:25:39 +0300
committerRichard Purdie <richard.purdie@linuxfoundation.org>2016-06-02 11:45:24 +0100
commit691032c4f0e424c3a097a015a14279ea0a6dd71d (patch)
treef09b57e28c8e9d7cf8b9a00cdfb989e1d6a35d3d /meta/recipes-devtools/python/python3-dbus_1.2.4.bb
parenta10fd8722fb7c5f2c5a206203d0c7f4237a86466 (diff)
downloadopenembedded-core-contrib-691032c4f0e424c3a097a015a14279ea0a6dd71d.tar.gz
python-dbus: update to 1.2.4, port to python 3
Signed-off-by: Alexander Kanavin <alexander.kanavin@linux.intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/python/python3-dbus_1.2.4.bb')
-rw-r--r--meta/recipes-devtools/python/python3-dbus_1.2.4.bb27
1 files changed, 27 insertions, 0 deletions
diff --git a/meta/recipes-devtools/python/python3-dbus_1.2.4.bb b/meta/recipes-devtools/python/python3-dbus_1.2.4.bb
new file mode 100644
index 0000000000..c058cafcf1
--- /dev/null
+++ b/meta/recipes-devtools/python/python3-dbus_1.2.4.bb
@@ -0,0 +1,27 @@
+SUMMARY = "Python bindings for the DBus inter-process communication system"
+SECTION = "devel/python"
+HOMEPAGE = "http://www.freedesktop.org/Software/dbus"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://COPYING;md5=0b83047ce9e948b67c0facc5f233476a"
+DEPENDS = "expat dbus dbus-glib virtual/libintl"
+
+SRC_URI = "http://dbus.freedesktop.org/releases/dbus-python/dbus-python-${PV}.tar.gz \
+"
+
+SRC_URI[md5sum] = "7372a588c83a7232b4e08159bfd48fe5"
+SRC_URI[sha256sum] = "e2f1d6871f74fba23652e51d10873e54f71adab0525833c19bad9e99b1b2f9cc"
+S = "${WORKDIR}/dbus-python-${PV}"
+
+inherit distutils3-base autotools pkgconfig
+
+PACKAGECONFIG ?= ""
+PACKAGECONFIG[docs] = "--enable-html-docs,--disable-html-docs,python-docutils-native"
+PACKAGECONFIG[api-docs] = "--enable-api-docs,--disable-api-docs,python-docutils-native python-epydoc-native"
+
+do_configure_prepend() {
+ export PYTHON=${PYTHON}
+}
+
+RDEPENDS_${PN} = "python3-io python3-logging python3-stringold python3-threading python3-xml"
+
+FILES_${PN}-dev += "${libdir}/pkgconfig"