summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/python/python3-cython_0.29.32.bb
diff options
context:
space:
mode:
authorRichard Purdie <richard.purdie@linuxfoundation.org>2023-01-04 15:03:39 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2023-01-05 11:52:15 +0000
commitb060a8a7e4c35f8404525f462189390e2dce81e5 (patch)
tree036d5743d9d895ef6a0598a409b8922d0aa58d22 /meta/recipes-devtools/python/python3-cython_0.29.32.bb
parent7a512a8803101310772d83836e6b78ebaf8121de (diff)
downloadopenembedded-core-contrib-b060a8a7e4c35f8404525f462189390e2dce81e5.tar.gz
python3-cython: Use PACKAGESPLITFUNCS instead of PACKAGEBUILDPKGD
The recipe can use the more commonly used PACKAGESPLITFUNCS instead of PACKAGEBUILDPKGD which is likely to be removed soon, there should be no change in behaviour. Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/python/python3-cython_0.29.32.bb')
-rw-r--r--meta/recipes-devtools/python/python3-cython_0.29.32.bb2
1 files changed, 1 insertions, 1 deletions
diff --git a/meta/recipes-devtools/python/python3-cython_0.29.32.bb b/meta/recipes-devtools/python/python3-cython_0.29.32.bb
index 8fed1cf94d..78be2b94ed 100644
--- a/meta/recipes-devtools/python/python3-cython_0.29.32.bb
+++ b/meta/recipes-devtools/python/python3-cython_0.29.32.bb
@@ -17,7 +17,7 @@ do_install:append() {
mv ${D}${bindir}/cygdb ${D}${bindir}/cygdb3
}
-PACKAGEBUILDPKGD += "cython_fix_sources"
+PACKAGESPLITFUNCS =+ "cython_fix_sources"
cython_fix_sources () {
for f in ${PKGD}/usr/src/debug/${PN}/${EXTENDPE}${PV}-${PR}/Cython/Compiler/FlowControl.c \