summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/python/python/run-ptest
diff options
context:
space:
mode:
authorTudor Florea <tudor.florea@enea.com>2013-07-19 17:10:59 +0200
committerSaul Wold <sgw@linux.intel.com>2013-07-22 09:44:10 -0700
commita768047cb8fc00ecf13f4db08117c348a9312c47 (patch)
tree3433e57b265f52d31cfccbc87e1bf67932b9ef84 /meta/recipes-devtools/python/python/run-ptest
parent0fcee1d02f98a40f38c622459e8b5ce3d39826ce (diff)
downloadopenembedded-core-contrib-a768047cb8fc00ecf13f4db08117c348a9312c47.tar.gz
python: Add ptest
Install python test suite and run it as ptest Signed-off-by: Tudor Florea <tudor.florea@enea.com> Signed-off-by: Saul Wold <sgw@linux.intel.com>
Diffstat (limited to 'meta/recipes-devtools/python/python/run-ptest')
-rw-r--r--meta/recipes-devtools/python/python/run-ptest5
1 files changed, 5 insertions, 0 deletions
diff --git a/meta/recipes-devtools/python/python/run-ptest b/meta/recipes-devtools/python/python/run-ptest
new file mode 100644
index 0000000000..a2f9eed444
--- /dev/null
+++ b/meta/recipes-devtools/python/python/run-ptest
@@ -0,0 +1,5 @@
+#!/bin/sh
+#
+#This script is used to run python test suites
+
+make -f LIBDIR/python/ptest/Makefile -k runtest-TESTS srcdir=LIBDIR/python2.7 TESTPROG=LIBDIR/python2.7/test/regrtest.py | sed -e '/\.\.\. ok/ s/^/PASS: /g' -e '/\.\.\. [ERROR|FAIL]/ s/^/FAIL: /g' -e '/\.\.\. skipped/ s/^/SKIP: /g' -e 's/ \.\.\. ok//g' -e 's/ \.\.\. ERROR//g' -e 's/ \.\.\. FAIL//g' -e 's/ \.\.\. skipped//g'