aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/python/python/python-2.7.3-remove-bsdb-rpath.patch
diff options
context:
space:
mode:
authorJackie Huang <jackie.huang@windriver.com>2012-08-04 21:14:08 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-08-06 14:17:22 +0100
commit11267f8a1ccf65142988b095351a84b0fa0fcbcf (patch)
tree1f1ae25b44971fe4fa202ca3f93ca670a932c2d2 /meta/recipes-devtools/python/python/python-2.7.3-remove-bsdb-rpath.patch
parent662637decc23888c9b0da93807257943bab14583 (diff)
downloadopenembedded-core-contrib-11267f8a1ccf65142988b095351a84b0fa0fcbcf.tar.gz
python: Fix to support the python module _bsddb built with db 5.3
_bsddb module in python 2.7 could be built only with db version between 4.1 and 4.7. A patch was added to avoid build warning about this for [YOCTO #1937] but not actually fixed it. This patch enable _bsddb module be built with db 5.3, and remove --disable-statistics from the DB5_CONFIG to fix segmentation fault when using _bsddb module in python. [YOCTO #2749] Signed-off-by: Jackie Huang <jackie.huang@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/python/python/python-2.7.3-remove-bsdb-rpath.patch')
-rw-r--r--meta/recipes-devtools/python/python/python-2.7.3-remove-bsdb-rpath.patch22
1 files changed, 22 insertions, 0 deletions
diff --git a/meta/recipes-devtools/python/python/python-2.7.3-remove-bsdb-rpath.patch b/meta/recipes-devtools/python/python/python-2.7.3-remove-bsdb-rpath.patch
new file mode 100644
index 0000000000..4b8953a137
--- /dev/null
+++ b/meta/recipes-devtools/python/python/python-2.7.3-remove-bsdb-rpath.patch
@@ -0,0 +1,22 @@
+Remove the RPTH to avoid QA issue warning.
+
+Signed-off-by: Jackie Huang <jackie.huang@windriver.com>
+---
+ setup.py | 1 -
+ 1 files changed, 0 insertions(+), 1 deletions(-)
+
+diff --git a/setup.py b/setup.py
+index 83b5e56..1fd5487 100644
+--- a/setup.py
++++ b/setup.py
+@@ -1025,7 +1025,6 @@ class PyBuildExt(build_ext):
+ exts.append(Extension('_bsddb', ['_bsddb.c'],
+ depends = ['bsddb.h'],
+ library_dirs=dblib_dir,
+- runtime_library_dirs=dblib_dir,
+ include_dirs=db_incs,
+ libraries=dblibs))
+ else:
+--
+1.7.4
+