summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/python/python/avoid_warning_for_sunos_specific_module.patch
diff options
context:
space:
mode:
authorRoss Burton <ross.burton@intel.com>2020-01-17 14:16:32 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2020-01-19 13:24:31 +0000
commit390f3edabfb1f68ed9766245291c5f44ea00cc38 (patch)
tree409a10d9cff7fa9a5b324565919112f55f55f86d /meta/recipes-devtools/python/python/avoid_warning_for_sunos_specific_module.patch
parentb22626d996e153d6094e1f76ed33ee1bb3eea751 (diff)
downloadopenembedded-core-contrib-390f3edabfb1f68ed9766245291c5f44ea00cc38.tar.gz
python: remove Python 2 and all supporting classes
Python 2 ceased being maintained on the 1st January 2020. We've already removed all users of it from oe-core so the final step is to move the recipe and supporting classes to meta-python2. The following are removed in this commit: - python and python-native 2.7.17 - python-setuptools - The classes pythonnative, pythondir, distutils, setuptools Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/python/python/avoid_warning_for_sunos_specific_module.patch')
-rw-r--r--meta/recipes-devtools/python/python/avoid_warning_for_sunos_specific_module.patch23
1 files changed, 0 insertions, 23 deletions
diff --git a/meta/recipes-devtools/python/python/avoid_warning_for_sunos_specific_module.patch b/meta/recipes-devtools/python/python/avoid_warning_for_sunos_specific_module.patch
deleted file mode 100644
index 8ba5823014..0000000000
--- a/meta/recipes-devtools/python/python/avoid_warning_for_sunos_specific_module.patch
+++ /dev/null
@@ -1,23 +0,0 @@
-sunaudiodev module is sunos specific so we avoid a warning by not
-adding this module to missing variable.
-
-Upstream-Status: Inappropriate [distribution]
-
-Signed-off-by: Andrei Gherzan <andrei@gherzan.ro>
-
-Index: Python-2.7.13/setup.py
-===================================================================
---- Python-2.7.13.orig/setup.py
-+++ Python-2.7.13/setup.py
-@@ -1671,8 +1671,9 @@ class PyBuildExt(build_ext):
- if host_platform == 'sunos5':
- # SunOS specific modules
- exts.append( Extension('sunaudiodev', ['sunaudiodev.c']) )
-- else:
-- missing.append('sunaudiodev')
-+ # If platform is not sunos warning is useless
-+ #else:
-+ # missing.append('sunaudiodev')
-
- if host_platform == 'darwin':
- # _scproxy