aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/python/python-smmap_0.9.0.bb
diff options
context:
space:
mode:
authorRobert Yang <liezhi.yang@windriver.com>2016-05-18 00:43:39 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2016-05-19 08:39:26 +0100
commit762c280259b90d2cb827b8f8dc62490e36bd7df8 (patch)
treec875331548d5fb3e337b4574083c8bc5c2117b41 /meta/recipes-devtools/python/python-smmap_0.9.0.bb
parent96189e71a86c0f4833e8e51d678208fd908bfe30 (diff)
downloadopenembedded-core-contrib-762c280259b90d2cb827b8f8dc62490e36bd7df8.tar.gz
python3-smmap: add it for python3-gitdb
Need add python3-git to buildtools-tarball for the py3 build, and the dependencies chain is: python3-git -> python3-gitdb -> python3-smmap Signed-off-by: Robert Yang <liezhi.yang@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/python/python-smmap_0.9.0.bb')
-rw-r--r--meta/recipes-devtools/python/python-smmap_0.9.0.bb20
1 files changed, 1 insertions, 19 deletions
diff --git a/meta/recipes-devtools/python/python-smmap_0.9.0.bb b/meta/recipes-devtools/python/python-smmap_0.9.0.bb
index 5f9cf452e3..c118dd8d63 100644
--- a/meta/recipes-devtools/python/python-smmap_0.9.0.bb
+++ b/meta/recipes-devtools/python/python-smmap_0.9.0.bb
@@ -1,23 +1,5 @@
-SUMMARY = "Python implementation of a sliding window memory map manager"
-DESCRIPTION = "A pure Python implementation of a sliding memory map to \
-help unifying memory mapped access on 32 and 64 bit systems and to help \
-managing resources more efficiently."
-HOMEPAGE = "http://github.com/gitpython-developers/GitPython"
-SECTION = "devel/python"
-LICENSE = "BSD"
-LIC_FILES_CHKSUM = "file://PKG-INFO;beginline=8;endline=8;md5=e910b35b0ef4e1f665b9a75d6afb7709"
-
-SRC_URI = "http://pypi.python.org/packages/source/s/smmap/smmap-${PV}.tar.gz"
-SRC_URI[md5sum] = "d7932d5ace206bf4ae15198cf36fb6ab"
-SRC_URI[sha256sum] = "0e2b62b497bd5f0afebc002eda4d90df9d209c30ef257e8673c90a6b5c119d62"
-
-UPSTREAM_CHECK_URI = "https://pypi.python.org/pypi/smmap/"
-UPSTREAM_CHECK_REGEX = "/smmap/(?P<pver>(\d+[\.\-_]*)+)"
-
-S = "${WORKDIR}/smmap-${PV}"
+require python-smmap.inc
inherit setuptools
RDEPENDS_${PN} += "python-codecs python-mmap python-lang"
-
-BBCLASSEXTEND = "nativesdk"