aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/python/python-smmap_0.9.0.bb
diff options
context:
space:
mode:
authorAlexander Kanavin <alexander.kanavin@linux.intel.com>2015-09-03 18:34:17 +0300
committerRichard Purdie <richard.purdie@linuxfoundation.org>2015-09-03 16:38:51 +0100
commit6341ff0ba66f690e28a3b1def90db50a8a8b497d (patch)
tree499c3ab8dae1986a15089f258c11a261e13acd5e /meta/recipes-devtools/python/python-smmap_0.9.0.bb
parent2f1f6820c42d995c1be04a60294f522cef4332f1 (diff)
downloadopenembedded-core-contrib-6341ff0ba66f690e28a3b1def90db50a8a8b497d.tar.gz
python-smmap: update to 0.9.0
Signed-off-by: Alexander Kanavin <alexander.kanavin@linux.intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/python/python-smmap_0.9.0.bb')
-rw-r--r--meta/recipes-devtools/python/python-smmap_0.9.0.bb20
1 files changed, 20 insertions, 0 deletions
diff --git a/meta/recipes-devtools/python/python-smmap_0.9.0.bb b/meta/recipes-devtools/python/python-smmap_0.9.0.bb
new file mode 100644
index 0000000000..b658be84c0
--- /dev/null
+++ b/meta/recipes-devtools/python/python-smmap_0.9.0.bb
@@ -0,0 +1,20 @@
+SUMMARY = "Python implementation of a sliding window memory map manager"
+DESCRIPTION = "A pure Python implementation of a sliding memory map to \
+help unifying memory mapped access on 32 and 64 bit systems and to help \
+managing resources more efficiently."
+HOMEPAGE = "http://github.com/gitpython-developers/GitPython"
+SECTION = "devel/python"
+LICENSE = "BSD"
+LIC_FILES_CHKSUM = "file://PKG-INFO;beginline=8;endline=8;md5=e910b35b0ef4e1f665b9a75d6afb7709"
+
+SRC_URI = "http://pypi.python.org/packages/source/s/smmap/smmap-${PV}.tar.gz"
+SRC_URI[md5sum] = "d7932d5ace206bf4ae15198cf36fb6ab"
+SRC_URI[sha256sum] = "0e2b62b497bd5f0afebc002eda4d90df9d209c30ef257e8673c90a6b5c119d62"
+
+S = "${WORKDIR}/smmap-${PV}"
+
+inherit setuptools
+
+RDEPENDS_${PN} += "python-codecs python-mmap python-lang"
+
+BBCLASSEXTEND = "nativesdk"