aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/python/python-setuptools_19.4.bb
diff options
context:
space:
mode:
authorAlejandro Hernandez <alejandro.hernandez@linux.intel.com>2016-01-21 16:46:06 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2016-01-22 23:42:45 +0000
commit7a42b4c01a0e1fa335ba1c679369d455235ea6ee (patch)
treedde6ed060f406dcac1268a4487bc15ab353e424f /meta/recipes-devtools/python/python-setuptools_19.4.bb
parentee0281c6c0ed92ba3eb69f55a1550b3c60d7981a (diff)
downloadopenembedded-core-contrib-7a42b4c01a0e1fa335ba1c679369d455235ea6ee.tar.gz
python-setuptools: Unify and upgrade python-setuptools and python3-setuptools to 19.4
Signed-off-by: Alejandro Hernandez <alejandro.hernandez@linux.intel.com> Signed-off-by: Ross Burton <ross.burton@intel.com>
Diffstat (limited to 'meta/recipes-devtools/python/python-setuptools_19.4.bb')
-rw-r--r--meta/recipes-devtools/python/python-setuptools_19.4.bb37
1 files changed, 37 insertions, 0 deletions
diff --git a/meta/recipes-devtools/python/python-setuptools_19.4.bb b/meta/recipes-devtools/python/python-setuptools_19.4.bb
new file mode 100644
index 0000000000..86bbebf081
--- /dev/null
+++ b/meta/recipes-devtools/python/python-setuptools_19.4.bb
@@ -0,0 +1,37 @@
+require python-setuptools.inc
+
+PROVIDES = "python-distribute"
+
+DEPENDS += "python"
+DEPENDS_class-native += "python-native"
+
+inherit distutils
+
+DISTUTILS_INSTALL_ARGS += "--install-lib=${D}${libdir}/${PYTHON_DIR}/site-packages"
+
+RDEPENDS_${PN} = "\
+ python-stringold \
+ python-email \
+ python-shell \
+ python-distutils \
+ python-compression \
+ python-pkgutil \
+ python-plistlib \
+ python-numbers \
+ python-html \
+ python-netserver \
+ python-ctypes \
+ python-subprocess \
+ python-unittest \
+"
+
+RDEPENDS_${PN}_class-native = "\
+ python-distutils \
+ python-compression \
+"
+
+RREPLACES_${PN} = "python-distribute"
+RPROVIDES_${PN} = "python-distribute"
+RCONFLICTS_${PN} = "python-distribute"
+
+BBCLASSEXTEND = "native nativesdk"