summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/python/python-scons_3.0.5.bb
diff options
context:
space:
mode:
authorAlexander Kanavin <alex.kanavin@gmail.com>2019-04-23 18:19:11 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2019-04-25 00:05:14 +0100
commitdd45da1c226bc87b4be5e9f065595aed316175a2 (patch)
treebfa52e800120e66280ea93ce915e955140fa4c24 /meta/recipes-devtools/python/python-scons_3.0.5.bb
parentd2e59735c11ae2dc2bc952414106d9395cc4a65c (diff)
downloadopenembedded-core-contrib-dd45da1c226bc87b4be5e9f065595aed316175a2.tar.gz
python-scons: update to 3.0.5
Do not use the latest pypi tarball, as it lacks several files (the LICENSE, for instance). License-update: copyright years. Signed-off-by: Alexander Kanavin <alex.kanavin@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/python/python-scons_3.0.5.bb')
-rw-r--r--meta/recipes-devtools/python/python-scons_3.0.5.bb24
1 files changed, 24 insertions, 0 deletions
diff --git a/meta/recipes-devtools/python/python-scons_3.0.5.bb b/meta/recipes-devtools/python/python-scons_3.0.5.bb
new file mode 100644
index 0000000000..939c15bcc6
--- /dev/null
+++ b/meta/recipes-devtools/python/python-scons_3.0.5.bb
@@ -0,0 +1,24 @@
+SUMMARY = "Software Construction tool (make/autotools replacement)"
+SECTION = "devel/python"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=37bb53a08e6beaea0c90e7821d731284"
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/scons/scons-${PV}.tar.gz"
+SRC_URI[md5sum] = "9f9c163e8bd48cf8cd92f03e85ca6395"
+SRC_URI[sha256sum] = "df676f23dc6d4bfa384fc389d95dcd21ab907e6349d4c848958ba4befb73c73e"
+
+S = "${WORKDIR}/scons-${PV}"
+
+UPSTREAM_CHECK_URI = "http://scons.org/pages/download.html"
+UPSTREAM_CHECK_REGEX = "(?P<pver>\d+(\.\d+)+)\.tar"
+
+inherit setuptools
+
+RDEPENDS_${PN} = "\
+ python-fcntl \
+ python-io \
+ python-json \
+ python-subprocess \
+ python-shell \
+ python-pprint \
+ "