summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/python/python-pycurl_7.19.0.2.bb
diff options
context:
space:
mode:
authorLaurentiu Palcu <laurentiu.palcu@intel.com>2013-11-05 11:25:17 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2013-11-05 22:17:51 +0000
commitbeaa98867954898f75c8a0987218a2caffb8daba (patch)
tree557fbb168d0b7c740ae193ad11f004d22d557083 /meta/recipes-devtools/python/python-pycurl_7.19.0.2.bb
parentf5bf674d0497a094682609b74da018e040f8d150 (diff)
downloadopenembedded-core-contrib-beaa98867954898f75c8a0987218a2caffb8daba.tar.gz
python-pycurl: upgrade to 7.19.0.2
Refreshed no-static-link.patch to work with this release and changed the lines/checksum (and the file) where the license can be found. Signed-off-by: Laurentiu Palcu <laurentiu.palcu@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/python/python-pycurl_7.19.0.2.bb')
-rw-r--r--meta/recipes-devtools/python/python-pycurl_7.19.0.2.bb34
1 files changed, 34 insertions, 0 deletions
diff --git a/meta/recipes-devtools/python/python-pycurl_7.19.0.2.bb b/meta/recipes-devtools/python/python-pycurl_7.19.0.2.bb
new file mode 100644
index 0000000000..fb57b49a93
--- /dev/null
+++ b/meta/recipes-devtools/python/python-pycurl_7.19.0.2.bb
@@ -0,0 +1,34 @@
+DESCRIPTION = "libcurl python bindings."
+HOMEPAGE = "http://pycurl.sourceforge.net/"
+SECTION = "devel/python"
+LICENSE = "LGPLv2.1+ | MIT"
+LIC_FILES_CHKSUM = "file://README.rst;beginline=97;endline=111;md5=b5a5e531d80812bcbecbeb240fde63ef \
+ file://COPYING;md5=3579a9fd0221d49a237aaa33492f988c \
+ file://COPYING2;md5=ffaa1e283b7f9bf5aafd8d45db6f7518"
+
+DEPENDS = "curl python"
+RDEPENDS_${PN} = "python-core curl"
+SRCNAME = "pycurl"
+
+SRC_URI = "\
+ http://${SRCNAME}.sourceforge.net/download/${SRCNAME}-${PV}.tar.gz;name=archive \
+ file://no-static-link.patch \
+"
+
+SRC_URI[archive.md5sum] = "518be33976dbc6838e42495ada64b43f"
+SRC_URI[archive.sha256sum] = "7a9e793b9181654d5eef3f6d22c244c57d2b51d38feb4c1b71d68efda99b0547"
+S = "${WORKDIR}/${SRCNAME}-${PV}"
+
+inherit distutils
+
+# need to export these variables for python-config to work
+export BUILD_SYS
+export HOST_SYS
+export STAGING_INCDIR
+export STAGING_LIBDIR
+
+BBCLASSEXTEND = "native"
+
+do_install_append() {
+ rm -rf ${D}${datadir}/share
+}