aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/python/python-ptyprocess_0.5.1.bb
diff options
context:
space:
mode:
authorAlejandro Hernandez <alejandro.hernandez@linux.intel.com>2016-06-08 05:56:12 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2016-06-12 23:36:54 +0100
commit8e29f954613fbc2eb274fc7e3da1d516353c4683 (patch)
treec697eb54467491fa0cde0d5c2da9578677dc3a8c /meta/recipes-devtools/python/python-ptyprocess_0.5.1.bb
parent84d54d198f6445ddd3c86d8ad6833f0d40a35ffd (diff)
downloadopenembedded-core-contrib-8e29f954613fbc2eb274fc7e3da1d516353c4683.tar.gz
python-pexpect: Upgrade from 4.0.1 to 4.1.0
Fixes source location, uses setuptools instead of distutils Adds python-ptyprocess package, since it is now a runtime dependency for python-pexpect Signed-off-by: Alejandro Hernandez <alejandro.hernandez@linux.intel.com> Signed-off-by: Ross Burton <ross.burton@intel.com>
Diffstat (limited to 'meta/recipes-devtools/python/python-ptyprocess_0.5.1.bb')
-rw-r--r--meta/recipes-devtools/python/python-ptyprocess_0.5.1.bb21
1 files changed, 21 insertions, 0 deletions
diff --git a/meta/recipes-devtools/python/python-ptyprocess_0.5.1.bb b/meta/recipes-devtools/python/python-ptyprocess_0.5.1.bb
new file mode 100644
index 0000000000..a9f7b4fd2c
--- /dev/null
+++ b/meta/recipes-devtools/python/python-ptyprocess_0.5.1.bb
@@ -0,0 +1,21 @@
+SUMMARY = "Run a subprocess in a pseudo terminal"
+HOMEPAGE = "http://ptyprocess.readthedocs.io/en/latest/"
+SECTION = "devel/python"
+LICENSE = "ISC"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=cfdcd51fa7d5808da4e74346ee394490"
+
+SRCNAME = "ptyprocess"
+
+SRC_URI = "https://files.pythonhosted.org/packages/source/p/${SRCNAME}/${SRCNAME}-${PV}.tar.gz"
+SRC_URI[md5sum] = "94e537122914cc9ec9c1eadcd36e73a1"
+SRC_URI[sha256sum] = "0530ce63a9295bfae7bd06edc02b6aa935619f486f0f1dc0972f516265ee81a6"
+
+UPSTREAM_CHECK_URI = "https://pypi.python.org/pypi/ptyprocess"
+
+S = "${WORKDIR}/${SRCNAME}-${PV}"
+
+inherit setuptools
+
+RDEPENDS_${PN} = "\
+ python-core \
+"