summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/python/python-pexpect_4.1.0.bb
diff options
context:
space:
mode:
authorAlejandro Hernandez <alejandro.hernandez@linux.intel.com>2016-06-08 05:56:12 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2016-06-12 23:36:54 +0100
commit8e29f954613fbc2eb274fc7e3da1d516353c4683 (patch)
treec697eb54467491fa0cde0d5c2da9578677dc3a8c /meta/recipes-devtools/python/python-pexpect_4.1.0.bb
parent84d54d198f6445ddd3c86d8ad6833f0d40a35ffd (diff)
downloadopenembedded-core-contrib-8e29f954613fbc2eb274fc7e3da1d516353c4683.tar.gz
python-pexpect: Upgrade from 4.0.1 to 4.1.0
Fixes source location, uses setuptools instead of distutils Adds python-ptyprocess package, since it is now a runtime dependency for python-pexpect Signed-off-by: Alejandro Hernandez <alejandro.hernandez@linux.intel.com> Signed-off-by: Ross Burton <ross.burton@intel.com>
Diffstat (limited to 'meta/recipes-devtools/python/python-pexpect_4.1.0.bb')
-rw-r--r--meta/recipes-devtools/python/python-pexpect_4.1.0.bb28
1 files changed, 28 insertions, 0 deletions
diff --git a/meta/recipes-devtools/python/python-pexpect_4.1.0.bb b/meta/recipes-devtools/python/python-pexpect_4.1.0.bb
new file mode 100644
index 0000000000..10590e4ab7
--- /dev/null
+++ b/meta/recipes-devtools/python/python-pexpect_4.1.0.bb
@@ -0,0 +1,28 @@
+SUMMARY = "A Pure Python Expect like Module for Python"
+HOMEPAGE = "http://pexpect.readthedocs.org/"
+SECTION = "devel/python"
+LICENSE = "ISC"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=66c2378a96b307d56bfb3a9e58edafa8"
+
+SRCNAME = "pexpect"
+
+SRC_URI = "https://files.pythonhosted.org/packages/source/p/${SRCNAME}/${SRCNAME}-${PV}.tar.gz"
+SRC_URI[md5sum] = "562a1a21f2a60b36dfd5d906dbf0943e"
+SRC_URI[sha256sum] = "c381c60f1987355b65df8f08a27f428831914c8a81091bd1778ac336fa2f27e7"
+
+UPSTREAM_CHECK_URI = "https://pypi.python.org/pypi/pexpect"
+
+S = "${WORKDIR}/pexpect-${PV}"
+
+inherit setuptools
+
+RDEPENDS_${PN} = "\
+ python-core \
+ python-io \
+ python-terminal \
+ python-resource \
+ python-fcntl \
+ python-ptyprocess \
+"
+
+BBCLASSEXTEND = "nativesdk"