aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/python/python-native_2.7.3.bb
diff options
context:
space:
mode:
authorRobert Yang <liezhi.yang@windriver.com>2013-05-08 16:29:48 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2013-05-10 11:41:10 +0100
commit165ed464bbb9bf985dde9d8c15d000809901fff6 (patch)
tree702a13c9d11a1e6df6f703a950ec64b922a302d5 /meta/recipes-devtools/python/python-native_2.7.3.bb
parent902d3fa57d4659ee12aac80246dcaca5c45f9d8c (diff)
downloadopenembedded-core-contrib-165ed464bbb9bf985dde9d8c15d000809901fff6.tar.gz
python: remove the default optimization
We had hard coded python-native and python's default optimization to 1, which made the "assert" statement didn't work, and removed the "-O/-OO" (optimization options), the target python had a "-N" option to disable the default optimization, but the native python didn't. I think that we can set the environment variable PYTHONOPTIMIZE or use "python -O" if we need to optimize, but I'm not sure whether we need to set it by default, it would confuse the user or cause/hide unexpected problems if the "assert" doesn't work. [YOCTO #4427] Signed-off-by: Robert Yang <liezhi.yang@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/python/python-native_2.7.3.bb')
-rw-r--r--meta/recipes-devtools/python/python-native_2.7.3.bb2
1 files changed, 1 insertions, 1 deletions
diff --git a/meta/recipes-devtools/python/python-native_2.7.3.bb b/meta/recipes-devtools/python/python-native_2.7.3.bb
index 162ecedb73..722d92c096 100644
--- a/meta/recipes-devtools/python/python-native_2.7.3.bb
+++ b/meta/recipes-devtools/python/python-native_2.7.3.bb
@@ -4,7 +4,7 @@ EXTRANATIVEPATH += "bzip2-native"
DEPENDS = "openssl-native bzip2-replacement-native zlib-native readline-native sqlite3-native"
PR = "${INC_PR}.1"
-SRC_URI += "file://04-default-is-optimized.patch \
+SRC_URI += "\
file://05-enable-ctypes-cross-build.patch \
file://06-ctypes-libffi-fix-configure.patch \
file://10-distutils-fix-swig-parameter.patch \