aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/python/python-native_2.7.13.bb
diff options
context:
space:
mode:
authorMing Liu <peter.x.liu@external.atlascopco.com>2017-02-26 08:39:19 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2017-03-01 15:50:19 +0000
commit0cb15d9559e34faffea1ac0be825d0602f225ba9 (patch)
treee664db11fcf6291ec0f720842cd6ff4d1a911a8f /meta/recipes-devtools/python/python-native_2.7.13.bb
parentd0902a5c3babbd3b291fa494462e083794ca4bee (diff)
downloadopenembedded-core-contrib-0cb15d9559e34faffea1ac0be825d0602f225ba9.tar.gz
generate-manifest-2.7.py: add logic to generate native manifest
python-native supposes to RPROVIDE all native packages as added in generate-manifest-2.7.py, but it does not so far, this leads a problem that sometimes bitbake cant find a runtime provider for a python-*-native when a new runtime dependency on it being required, this usualy happens after a new native python-* recipe is created or the old native python-* recipes are upgraded. To give a example, the following commit is trying to address such a issue: commit 4583cd1bb15306e8f0ab7bcd80732e6f35aa4533: [ python-native: Make python-native also RPROVIDE python-unittest-native ] To avoid manually extending RPROVIDE every time when a new runtime dependency is introduced, an argument '-n/--native' is added to the manifest generator, allowing it create a native python manifest, with a RPROVIDE line only, the RPROVIDE should contain all the sub-packages. The generated python-native-2.7-manifest.inc is also added which is included by python-native recipe. Signed-off-by: Ming Liu <peter.x.liu@external.atlascopco.com> Signed-off-by: Ross Burton <ross.burton@intel.com>
Diffstat (limited to 'meta/recipes-devtools/python/python-native_2.7.13.bb')
-rw-r--r--meta/recipes-devtools/python/python-native_2.7.13.bb9
1 files changed, 1 insertions, 8 deletions
diff --git a/meta/recipes-devtools/python/python-native_2.7.13.bb b/meta/recipes-devtools/python/python-native_2.7.13.bb
index 9a6430dba5..7edf153489 100644
--- a/meta/recipes-devtools/python/python-native_2.7.13.bb
+++ b/meta/recipes-devtools/python/python-native_2.7.13.bb
@@ -25,14 +25,7 @@ FILESEXTRAPATHS =. "${FILE_DIRNAME}/${PN}:"
inherit native
-RPROVIDES += "python-distutils-native \
- python-compression-native \
- python-textutils-native \
- python-codecs-native \
- python-core-native \
- python-unittest-native \
- python-io-native \
-"
+require python-native-${PYTHON_MAJMIN}-manifest.inc
EXTRA_OECONF_append = " --bindir=${bindir}/${PN} --with-system-expat=${STAGING_DIR_HOST}"