aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/python/python-mako_1.0.3.bb
diff options
context:
space:
mode:
authorAlexander Kanavin <alexander.kanavin@linux.intel.com>2016-05-11 16:36:37 +0300
committerRichard Purdie <richard.purdie@linuxfoundation.org>2016-06-01 08:04:11 +0100
commit72be3752a56d681672fb3e04413ff3cc59391150 (patch)
tree76b81efa64b9c80202e06437515386127e1092b5 /meta/recipes-devtools/python/python-mako_1.0.3.bb
parenta5aa15188b0c43432251039adc82c6c5cc453b2e (diff)
downloadopenembedded-core-contrib-72be3752a56d681672fb3e04413ff3cc59391150.tar.gz
python3-mako: add a Python 3 recipe
This will be necessary for transiting piglit to Python 3. Python 2 recipe should be kept as it is used by mesa (and gobject-introspection, for now). Signed-off-by: Alexander Kanavin <alexander.kanavin@linux.intel.com>
Diffstat (limited to 'meta/recipes-devtools/python/python-mako_1.0.3.bb')
-rw-r--r--meta/recipes-devtools/python/python-mako_1.0.3.bb6
1 files changed, 6 insertions, 0 deletions
diff --git a/meta/recipes-devtools/python/python-mako_1.0.3.bb b/meta/recipes-devtools/python/python-mako_1.0.3.bb
index 9efd700dc0..d4f426dadd 100644
--- a/meta/recipes-devtools/python/python-mako_1.0.3.bb
+++ b/meta/recipes-devtools/python/python-mako_1.0.3.bb
@@ -22,3 +22,9 @@ RDEPENDS_${PN} = "python-threading \
RDEPENDS_${PN}_class-native = ""
BBCLASSEXTEND = "native nativesdk"
+
+# The same utility is packaged in python3-mako, so it would conflict
+do_install_append() {
+ rm -f ${D}${bindir}/mako-render
+ rm -df ${D}${bindir}
+}