aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/python/python-git_1.0.1.bb
diff options
context:
space:
mode:
authorAlexander Kanavin <alexander.kanavin@linux.intel.com>2015-11-16 15:26:42 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2015-12-08 10:20:09 +0000
commit9528cff2ecf4241cb80d9e972751d7ac607d39e4 (patch)
tree4392d789af3c0aa43241a2884c0c2c0f9275a032 /meta/recipes-devtools/python/python-git_1.0.1.bb
parent2a5e1848c11bd9a3c64cf8fcc0cb334c738bc5c5 (diff)
downloadopenembedded-core-contrib-9528cff2ecf4241cb80d9e972751d7ac607d39e4.tar.gz
package_regex.inc: split PyPi related entries to their own recipes
Signed-off-by: Alexander Kanavin <alexander.kanavin@linux.intel.com> Signed-off-by: Ross Burton <ross.burton@intel.com>
Diffstat (limited to 'meta/recipes-devtools/python/python-git_1.0.1.bb')
-rw-r--r--meta/recipes-devtools/python/python-git_1.0.1.bb3
1 files changed, 3 insertions, 0 deletions
diff --git a/meta/recipes-devtools/python/python-git_1.0.1.bb b/meta/recipes-devtools/python/python-git_1.0.1.bb
index e1509e6c20..5230e2182d 100644
--- a/meta/recipes-devtools/python/python-git_1.0.1.bb
+++ b/meta/recipes-devtools/python/python-git_1.0.1.bb
@@ -14,6 +14,9 @@ SRC_URI = "http://pypi.python.org/packages/source/G/GitPython/GitPython-${PV}.ta
SRC_URI[md5sum] = "4659644b42c41e5e5170c0cd83ed6422"
SRC_URI[sha256sum] = "9c88c17bbcae2a445ff64024ef13526224f70e35e38c33416be5ceb56ca7f760"
+UPSTREAM_CHECK_URI = "https://pypi.python.org/pypi/GitPython/"
+UPSTREAM_CHECK_REGEX = "/GitPython/(?P<pver>(\d+[\.\-_]*)+)"
+
S = "${WORKDIR}/GitPython-${PV}"
inherit setuptools