aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/python/python-dbus_1.2.0.bb
diff options
context:
space:
mode:
authorBogdan Marinescu <bogdan.a.marinescu@intel.com>2013-05-27 14:41:50 +0300
committerSaul Wold <sgw@linux.intel.com>2013-05-29 08:19:04 +0900
commitccf27bfe1269df74fa00b77447fecfe2368c0191 (patch)
tree80fd46d74dd43793fcdfbe747a1820d7ba820cd6 /meta/recipes-devtools/python/python-dbus_1.2.0.bb
parent7d1ab4fe3bd78799b2e6401c6413d43655de348e (diff)
downloadopenembedded-core-contrib-ccf27bfe1269df74fa00b77447fecfe2368c0191.tar.gz
python-dbus: upgraded to 1.2.0
The license itself didn't modify, just some comments regarding the license. Signed-off-by: Bogdan Marinescu <bogdan.a.marinescu@intel.com> Signed-off-by: Saul Wold <sgw@linux.intel.com>
Diffstat (limited to 'meta/recipes-devtools/python/python-dbus_1.2.0.bb')
-rw-r--r--meta/recipes-devtools/python/python-dbus_1.2.0.bb25
1 files changed, 25 insertions, 0 deletions
diff --git a/meta/recipes-devtools/python/python-dbus_1.2.0.bb b/meta/recipes-devtools/python/python-dbus_1.2.0.bb
new file mode 100644
index 0000000000..a185d841e2
--- /dev/null
+++ b/meta/recipes-devtools/python/python-dbus_1.2.0.bb
@@ -0,0 +1,25 @@
+DESCRIPTION = "Python bindings for DBus, a socket-based message bus system for interprocess communication"
+SECTION = "devel/python"
+HOMEPAGE = "http://www.freedesktop.org/Software/dbus"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://COPYING;md5=0b83047ce9e948b67c0facc5f233476a"
+DEPENDS = "expat dbus dbus-glib virtual/libintl python-pyrex-native"
+
+SRC_URI = "http://dbus.freedesktop.org/releases/dbus-python/dbus-python-${PV}.tar.gz \
+"
+
+SRC_URI[md5sum] = "b09cd2d1a057cc432ce944de3fc06bf7"
+SRC_URI[sha256sum] = "e12c6c8b2bf3a9302f75166952cbe41d6b38c3441bbc6767dbd498942316c6df"
+S = "${WORKDIR}/dbus-python-${PV}"
+
+inherit distutils-base autotools pkgconfig
+
+export BUILD_SYS
+export HOST_SYS
+
+export STAGING_LIBDIR
+export STAGING_INCDIR
+
+RDEPENDS_${PN} = "python-io python-logging python-stringold python-threading python-xml"
+
+FILES_${PN}-dev += "${libdir}/pkgconfig"