aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/python-numpy/files/mipsarcho32el/numpyconfig.h
diff options
context:
space:
mode:
authorZubair Lutfullah Kakakhel <Zubair.Kakakhel@imgtec.com>2016-11-23 13:47:30 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2016-11-30 15:47:12 +0000
commita48dbddab9524e78eeac53484d9dbfa0b484c561 (patch)
tree8537ea2388817fce54d9db23b3c5746be9d24f49 /meta/recipes-devtools/python-numpy/files/mipsarcho32el/numpyconfig.h
parent85280798306c0c1b1f36e5a10394ffaa7c4041f9 (diff)
downloadopenembedded-core-contrib-a48dbddab9524e78eeac53484d9dbfa0b484c561.tar.gz
python-numpy: Use MIPS MACHINE_OVERRIDES to reduce duplication
The mipsarch* MACHINE_OVERRIDES can be used to pass the same parameters to MIPS pre-R2 and R6 ISA variants. Use them to reduce duplication in supporting MIPS R6 ISA. Signed-off-by: Zubair Lutfullah Kakakhel <Zubair.Kakakhel@imgtec.com> Signed-off-by: Ross Burton <ross.burton@intel.com>
Diffstat (limited to 'meta/recipes-devtools/python-numpy/files/mipsarcho32el/numpyconfig.h')
-rw-r--r--meta/recipes-devtools/python-numpy/files/mipsarcho32el/numpyconfig.h18
1 files changed, 18 insertions, 0 deletions
diff --git a/meta/recipes-devtools/python-numpy/files/mipsarcho32el/numpyconfig.h b/meta/recipes-devtools/python-numpy/files/mipsarcho32el/numpyconfig.h
new file mode 100644
index 0000000000..0b7cd51af4
--- /dev/null
+++ b/meta/recipes-devtools/python-numpy/files/mipsarcho32el/numpyconfig.h
@@ -0,0 +1,18 @@
+/* cat ./src.linux-i686-2.5/numpy/core/include/numpy/numpyconfig.h */
+/*
+ * * This file is generated by numpy/core/setup.pyc. DO NOT EDIT
+ * */
+#define NPY_SIZEOF_SHORT 2
+#define NPY_SIZEOF_INT 4
+#define NPY_SIZEOF_LONG 4
+#define NPY_SIZEOF_FLOAT 4
+#define NPY_SIZEOF_DOUBLE 8
+#define NPY_SIZEOF_LONGDOUBLE 12
+#define NPY_SIZEOF_PY_INTPTR_T 4
+#define NPY_NO_SMP 0
+
+#define NPY_SIZEOF_LONGLONG 8
+#define NPY_SIZEOF_PY_LONG_LONG 8
+#define NPY_SIZEOF_OFF_T 8
+/* #define CHAR_BIT 8 */
+