summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/python-numpy/files/0001-numpy-random-setup.py-remove-the-detection-of-x86-ta.patch
diff options
context:
space:
mode:
authorRoss Burton <ross.burton@intel.com>2019-12-02 18:09:17 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2019-12-04 12:29:29 +0000
commit33d9d696f3a865a51c0a16a0a65a8028642be4d7 (patch)
tree69a3ce8406ebfdfdae6940f0011aea12a1a8c823 /meta/recipes-devtools/python-numpy/files/0001-numpy-random-setup.py-remove-the-detection-of-x86-ta.patch
parentbd40260cbacf660e7390f4f5ef5e096e75774b05 (diff)
downloadopenembedded-core-contrib-33d9d696f3a865a51c0a16a0a65a8028642be4d7.tar.gz
python-numpy: upgrade to 1.17.4
Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/python-numpy/files/0001-numpy-random-setup.py-remove-the-detection-of-x86-ta.patch')
-rw-r--r--meta/recipes-devtools/python-numpy/files/0001-numpy-random-setup.py-remove-the-detection-of-x86-ta.patch4
1 files changed, 2 insertions, 2 deletions
diff --git a/meta/recipes-devtools/python-numpy/files/0001-numpy-random-setup.py-remove-the-detection-of-x86-ta.patch b/meta/recipes-devtools/python-numpy/files/0001-numpy-random-setup.py-remove-the-detection-of-x86-ta.patch
index ebb2a6f9df..9da6a2b3da 100644
--- a/meta/recipes-devtools/python-numpy/files/0001-numpy-random-setup.py-remove-the-detection-of-x86-ta.patch
+++ b/meta/recipes-devtools/python-numpy/files/0001-numpy-random-setup.py-remove-the-detection-of-x86-ta.patch
@@ -22,8 +22,8 @@ index a1bf3b8..60fb534 100644
elif not is_msvc:
# Some bit generators require c99
EXTRA_COMPILE_ARGS += ['-std=c99']
-- INTEL_LIKE = any([val in k.lower() for k in platform.uname()
-- for val in ('x86', 'i686', 'i386', 'amd64')])
+- INTEL_LIKE = any(arch in platform.machine()
+- for arch in ('x86', 'i686', 'i386', 'amd64'))
- if INTEL_LIKE:
- # Assumes GCC or GCC-like compiler
- EXTRA_COMPILE_ARGS += ['-msse2']