aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/pseudo
diff options
context:
space:
mode:
authorRichard Purdie <richard.purdie@linuxfoundation.org>2011-02-10 10:34:40 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2011-02-10 12:01:04 +0000
commitb1c0b3de20385457fdba4786c5cd11ef9024e6af (patch)
tree440c90a7cdbf82d25f46b8b496771d83bb0c50c4 /meta/recipes-devtools/pseudo
parent0b50dc8ed66058251349f1d471f75623f9a2fb8b (diff)
downloadopenembedded-core-contrib-b1c0b3de20385457fdba4786c5cd11ef9024e6af.tar.gz
pseudo: Add and use the 1.0 release version
Not using the git version has the advantage of removing several early bootstrap dependencies such as git-native (which pulls in perl and openssl). Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/pseudo')
-rw-r--r--meta/recipes-devtools/pseudo/pseudo.inc69
-rw-r--r--meta/recipes-devtools/pseudo/pseudo_1.0.bb9
-rw-r--r--meta/recipes-devtools/pseudo/pseudo_git.bb74
3 files changed, 81 insertions, 71 deletions
diff --git a/meta/recipes-devtools/pseudo/pseudo.inc b/meta/recipes-devtools/pseudo/pseudo.inc
new file mode 100644
index 0000000000..a458dcce69
--- /dev/null
+++ b/meta/recipes-devtools/pseudo/pseudo.inc
@@ -0,0 +1,69 @@
+DESCRIPTION = "Pseudo gives fake root capabilities to a normal user"
+HOMEPAGE = "http://wiki.github.com/wrpseudo/pseudo/"
+LIC_FILES_CHKSUM = "file://COPYING;md5=243b725d71bb5df4a1e5920b344b86ad"
+SECTION = "base"
+LICENSE = "LGPL2.1"
+DEPENDS = "sqlite3"
+
+FILES_${PN} = "${libdir}/libpseudo.so ${bindir}/* ${localstatedir}/pseudo"
+PROVIDES += "virtual/fakeroot"
+
+inherit siteinfo
+
+do_configure () {
+ :
+}
+
+NO32LIBS ??= "0"
+
+# Compile for the local machine arch...
+do_compile () {
+ ${S}/configure --prefix=${prefix} --with-sqlite=${STAGING_DIR_TARGET}${exec_prefix} --bits=${SITEINFO_BITS}
+ oe_runmake 'LIB=lib/pseudo/lib$(MARK64)'
+}
+
+# Two below are the same
+# If necessary compile for the alternative machine arch. This is only
+# necessary in a native build.
+do_compile_prepend_virtclass-native () {
+ if [ "${SITEINFO_BITS}" == "64" -a -e "/usr/include/gnu/stubs-32.h" -a "${PN}" == "pseudo-native" -a "${NO32LIBS}" != "1" ]; then
+ # We need the 32-bit libpseudo on a 64-bit machine...
+ ./configure --prefix=${prefix} --with-sqlite=${STAGING_DIR_TARGET}${exec_prefix} --bits=32
+ oe_runmake 'CFLAGS=-m32' 'LIB=lib/pseudo/lib' libpseudo
+ # prevent it from removing the lib, but remove everything else
+ make 'LIB=foo' distclean
+ fi
+}
+
+do_compile_prepend_virtclass-nativesdk () {
+ if [ "${SITEINFO_BITS}" == "64" -a -e "/usr/include/gnu/stubs-32.h" -a "${PN}" == "pseudo-native" -a "${NO32LIBS}" != "1" ]; then
+ # We need the 32-bit libpseudo on a 64-bit machine...
+ ./configure --prefix=${prefix} --with-sqlite=${STAGING_DIR_TARGET}${exec_prefix} --bits=32
+ oe_runmake 'CFLAGS=-m32' 'LIB=lib/pseudo/lib' libpseudo
+ # prevent it from removing the lib, but remove everything else
+ make 'LIB=foo' distclean
+ fi
+}
+
+do_install () {
+ oe_runmake 'DESTDIR=${D}' 'LIB=lib/pseudo/lib$(MARK64)' install
+}
+
+# Two below are the same
+# If necessary install for the alternative machine arch. This is only
+# necessary in a native build.
+do_install_append_virtclass-native () {
+ if [ "${SITEINFO_BITS}" == "64" -a -e "/usr/include/gnu/stubs-32.h" -a "${PN}" == "pseudo-native" -a "${NO32LIBS}" != "1" ]; then
+ mkdir -p ${D}${prefix}/lib/pseudo/lib
+ cp lib/pseudo/lib/libpseudo.so ${D}${prefix}/lib/pseudo/lib/.
+ fi
+}
+
+do_install_append_virtclass-nativesdk () {
+ if [ "${SITEINFO_BITS}" == "64" -a -e "/usr/include/gnu/stubs-32.h" -a "${PN}" == "pseudo-native" -a "${NO32LIBS}" != "1" ]; then
+ mkdir -p ${D}${prefix}/lib/pseudo/lib
+ cp lib/pseudo/lib/libpseudo.so ${D}${prefix}/lib/pseudo/lib/.
+ fi
+}
+
+BBCLASSEXTEND = "native nativesdk"
diff --git a/meta/recipes-devtools/pseudo/pseudo_1.0.bb b/meta/recipes-devtools/pseudo/pseudo_1.0.bb
new file mode 100644
index 0000000000..e750e8aebc
--- /dev/null
+++ b/meta/recipes-devtools/pseudo/pseudo_1.0.bb
@@ -0,0 +1,9 @@
+require pseudo.inc
+
+PR = "r0"
+
+SRC_URI = "http://www.yoctoproject.org/downloads/${BPN}/${BPN}-${PV}.tar.bz2 \
+ file://static_sqlite.patch"
+
+SRC_URI[md5sum] = "a329bd00ba78711bcacd48fc1982af6a"
+SRC_URI[sha256sum] = "cb41c97094044144ef4027ab9dbba009f3cb1c23e6bec9640f29d530524ad60f"
diff --git a/meta/recipes-devtools/pseudo/pseudo_git.bb b/meta/recipes-devtools/pseudo/pseudo_git.bb
index 244fabe1eb..8fe311082d 100644
--- a/meta/recipes-devtools/pseudo/pseudo_git.bb
+++ b/meta/recipes-devtools/pseudo/pseudo_git.bb
@@ -1,78 +1,10 @@
-DESCRIPTION = "Pseudo gives fake root capabilities to a normal user"
-HOMEPAGE = "http://wiki.github.com/wrpseudo/pseudo/"
-LIC_FILES_CHKSUM = "file://COPYING;md5=243b725d71bb5df4a1e5920b344b86ad"
-SECTION = "base"
-LICENSE = "LGPL2.1"
-DEPENDS = "sqlite3"
+require pseudo.inc
-PV = "0.0+git${SRCPV}"
+PV = "1.0+git${SRCPV}"
PR = "r18"
SRC_URI = "git://github.com/wrpseudo/pseudo.git;protocol=git \
- file://static_sqlite.patch \
- "
-
-FILES_${PN} = "${libdir}/libpseudo.so ${bindir}/* ${localstatedir}/pseudo"
-PROVIDES += "virtual/fakeroot"
+ file://static_sqlite.patch"
S = "${WORKDIR}/git"
-inherit siteinfo
-
-do_configure () {
- :
-}
-
-NO32LIBS ??= "0"
-
-# Compile for the local machine arch...
-do_compile () {
- ${S}/configure --prefix=${prefix} --with-sqlite=${STAGING_DIR_TARGET}${exec_prefix} --bits=${SITEINFO_BITS}
- oe_runmake 'LIB=lib/pseudo/lib$(MARK64)'
-}
-
-# Two below are the same
-# If necessary compile for the alternative machine arch. This is only
-# necessary in a native build.
-do_compile_prepend_virtclass-native () {
- if [ "${SITEINFO_BITS}" == "64" -a -e "/usr/include/gnu/stubs-32.h" -a "${PN}" == "pseudo-native" -a "${NO32LIBS}" != "1" ]; then
- # We need the 32-bit libpseudo on a 64-bit machine...
- ./configure --prefix=${prefix} --with-sqlite=${STAGING_DIR_TARGET}${exec_prefix} --bits=32
- oe_runmake 'CFLAGS=-m32' 'LIB=lib/pseudo/lib' libpseudo
- # prevent it from removing the lib, but remove everything else
- make 'LIB=foo' distclean
- fi
-}
-
-do_compile_prepend_virtclass-nativesdk () {
- if [ "${SITEINFO_BITS}" == "64" -a -e "/usr/include/gnu/stubs-32.h" -a "${PN}" == "pseudo-native" -a "${NO32LIBS}" != "1" ]; then
- # We need the 32-bit libpseudo on a 64-bit machine...
- ./configure --prefix=${prefix} --with-sqlite=${STAGING_DIR_TARGET}${exec_prefix} --bits=32
- oe_runmake 'CFLAGS=-m32' 'LIB=lib/pseudo/lib' libpseudo
- # prevent it from removing the lib, but remove everything else
- make 'LIB=foo' distclean
- fi
-}
-
-do_install () {
- oe_runmake 'DESTDIR=${D}' 'LIB=lib/pseudo/lib$(MARK64)' install
-}
-
-# Two below are the same
-# If necessary install for the alternative machine arch. This is only
-# necessary in a native build.
-do_install_append_virtclass-native () {
- if [ "${SITEINFO_BITS}" == "64" -a -e "/usr/include/gnu/stubs-32.h" -a "${PN}" == "pseudo-native" -a "${NO32LIBS}" != "1" ]; then
- mkdir -p ${D}${prefix}/lib/pseudo/lib
- cp lib/pseudo/lib/libpseudo.so ${D}${prefix}/lib/pseudo/lib/.
- fi
-}
-
-do_install_append_virtclass-nativesdk () {
- if [ "${SITEINFO_BITS}" == "64" -a -e "/usr/include/gnu/stubs-32.h" -a "${PN}" == "pseudo-native" -a "${NO32LIBS}" != "1" ]; then
- mkdir -p ${D}${prefix}/lib/pseudo/lib
- cp lib/pseudo/lib/libpseudo.so ${D}${prefix}/lib/pseudo/lib/.
- fi
-}
-
-BBCLASSEXTEND = "native nativesdk"