summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/pseudo/pseudo_git.bb
diff options
context:
space:
mode:
authorRobert Yang <liezhi.yang@windriver.com>2019-11-25 19:09:53 +0800
committerRobert Yang <liezhi.yang@windriver.com>2019-12-24 15:15:38 +0800
commitb763cef4b8957d8140800d46391150599ef56c55 (patch)
tree42ce2571cfbf1568451f29b8b27377bd63fc5967 /meta/recipes-devtools/pseudo/pseudo_git.bb
parentd6c62cc0305ab082e990041da104fedb5798e0e4 (diff)
downloadopenembedded-core-contrib-rbt/pseudo.tar.gz
pseudo: Make realpath() remove trailing slashesrbt/pseudo
Linux system's realpath() remove trailing slashes, but pseudo's doesn't, need make them identical. E.g., the following code (rel.c) prints '/tmp' with system's realpath, but pseudo's realpath prints '/tmp/': #include <stdio.h> #include <limits.h> #include <stdlib.h> int main() { char out[PATH_MAX]; printf("%s\n", realpath("/tmp/", out)); return 0; } $ bitbake base-passwd -cdevshell # For pseudo env $ gcc rel.c $ ./a.out /tmp/ (but should be /tmp) This patch fixes the problem. Signed-off-by: Robert Yang <liezhi.yang@windriver.com>
Diffstat (limited to 'meta/recipes-devtools/pseudo/pseudo_git.bb')
-rw-r--r--meta/recipes-devtools/pseudo/pseudo_git.bb1
1 files changed, 1 insertions, 0 deletions
diff --git a/meta/recipes-devtools/pseudo/pseudo_git.bb b/meta/recipes-devtools/pseudo/pseudo_git.bb
index 1f2df4a427..7c75293ef1 100644
--- a/meta/recipes-devtools/pseudo/pseudo_git.bb
+++ b/meta/recipes-devtools/pseudo/pseudo_git.bb
@@ -8,6 +8,7 @@ SRC_URI = "git://git.yoctoproject.org/pseudo \
file://toomanyfiles.patch \
file://0001-maketables-wrappers-use-Python-3.patch \
file://0001-Add-statx.patch \
+ file://0001-realpath.c-Remove-trailing-slashes.patch \
"
SRCREV = "060058bb29f70b244e685b3c704eb0641b736f73"