aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/pseudo/pseudo_1.6.4.bb
diff options
context:
space:
mode:
authorPeter Seebach <peter.seebach@windriver.com>2015-01-22 20:23:56 -0600
committerRichard Purdie <richard.purdie@linuxfoundation.org>2015-01-28 21:22:21 +0000
commit67298d4fe6d96692a4e0578a44cc1a0bbf2cdc2b (patch)
treef156eaaead51ca3294af1ea317a4264bd6c912dd /meta/recipes-devtools/pseudo/pseudo_1.6.4.bb
parent2a775ebbb175dd70fc7228607c306d4ccb9e4ba4 (diff)
downloadopenembedded-core-contrib-67298d4fe6d96692a4e0578a44cc1a0bbf2cdc2b.tar.gz
pseudo_1.6.x.bb/pseudo_git.bb: Pseudo 1.6.4
pseudo 1.6.3 merges (with some changes) the changes from Peter A. Bigot to make --without-fallback-passwd work. It also adds a proposed fix for Yocto bug #7097, which has passed the obvious tests I could think of. pseudo 1.6.4 fixes a silly configure bug introduced with 1.6.3. [YOCTO: #7097] Signed-off-by: Peter Seebach <peter.seebach@windriver.com> Signed-off-by: Ross Burton <ross.burton@intel.com>
Diffstat (limited to 'meta/recipes-devtools/pseudo/pseudo_1.6.4.bb')
-rw-r--r--meta/recipes-devtools/pseudo/pseudo_1.6.4.bb19
1 files changed, 19 insertions, 0 deletions
diff --git a/meta/recipes-devtools/pseudo/pseudo_1.6.4.bb b/meta/recipes-devtools/pseudo/pseudo_1.6.4.bb
new file mode 100644
index 0000000000..3d5b1fbd3e
--- /dev/null
+++ b/meta/recipes-devtools/pseudo/pseudo_1.6.4.bb
@@ -0,0 +1,19 @@
+require pseudo.inc
+
+SRC_URI = " \
+ http://www.yoctoproject.org/downloads/${BPN}/${BPN}-${PV}.tar.bz2 \
+ file://fallback-passwd \
+ file://fallback-group \
+"
+
+SRC_URI[md5sum] = "2fb800c90d643bfce55e1ce5ca67f3b3"
+SRC_URI[sha256sum] = "25a7528f9191f74cceccc08a90c00086f2b3a9f6b900ea419a4f092de9a06775"
+
+PSEUDO_EXTRA_OPTS ?= "--enable-force-async --without-passwd-fallback"
+
+do_install_append_class-native () {
+ install -d ${D}${sysconfdir}
+ # The fallback files should never be modified
+ install -m 444 ${WORKDIR}/fallback-passwd ${D}${sysconfdir}/passwd
+ install -m 444 ${WORKDIR}/fallback-group ${D}${sysconfdir}/group
+}