aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/pseudo/pseudo_1.6.2.bb
diff options
context:
space:
mode:
authorPeter A. Bigot <pab@pabigot.com>2014-11-01 06:48:03 -0500
committerRichard Purdie <richard.purdie@linuxfoundation.org>2014-11-25 12:58:21 +0000
commit91443426246fbe13083c19801b7c74365e041271 (patch)
treeca2e83f9c50cf4e70c7d05d3a37fe8805bc69768 /meta/recipes-devtools/pseudo/pseudo_1.6.2.bb
parent899fe3d1d05054a10e4d427810c20ad1e34f916a (diff)
downloadopenembedded-core-contrib-91443426246fbe13083c19801b7c74365e041271.tar.gz
pseudo: provide fallback passwd and group files
Normally pseudo is built with --without-passwd-fallback, which requires that somebody provide target passwd and group files. Those come from base-passwd in OE, but base-passwd cannot be built without first invoking operations under pseudo that require getpw*/getgr*. Provide the absolute minimum stub files, matching in content what will eventually be on the target, that can be used in the cases where the target files are not yet available. The requirements for minimum stub are the usernames and groups identified in meta/files/fs-perms.txt. Signed-off-by: Peter A. Bigot <pab@pabigot.com>
Diffstat (limited to 'meta/recipes-devtools/pseudo/pseudo_1.6.2.bb')
-rw-r--r--meta/recipes-devtools/pseudo/pseudo_1.6.2.bb9
1 files changed, 9 insertions, 0 deletions
diff --git a/meta/recipes-devtools/pseudo/pseudo_1.6.2.bb b/meta/recipes-devtools/pseudo/pseudo_1.6.2.bb
index fb85f896e4..261c8d3abd 100644
--- a/meta/recipes-devtools/pseudo/pseudo_1.6.2.bb
+++ b/meta/recipes-devtools/pseudo/pseudo_1.6.2.bb
@@ -5,9 +5,18 @@ SRC_URI = " \
file://0001-pseudo_client.c-protect-pwd_lck-against-magic.patch \
file://0002-pseudo_util-modify-interface-to-pseudo_etc_file.patch \
file://0003-pseudo_client.c-support-multiple-directories-in-PSEU.patch \
+ file://fallback-passwd \
+ file://fallback-group \
"
SRC_URI[md5sum] = "4d7b4f9d1b4aafa680ce94a5a9a52f1f"
SRC_URI[sha256sum] = "c72be92689511ced7c419149c6aaa1b1a9e4dfc6409d1f16ab72cc35bc1e376a"
PSEUDO_EXTRA_OPTS ?= "--enable-force-async --without-passwd-fallback"
+
+do_install_append_class-native () {
+ install -d ${D}${sysconfdir}
+ # The fallback files should never be modified
+ install -m 444 ${WORKDIR}/fallback-passwd ${D}${sysconfdir}/passwd
+ install -m 444 ${WORKDIR}/fallback-group ${D}${sysconfdir}/group
+}