summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/perl
diff options
context:
space:
mode:
authorTim Orling <timothy.t.orling@linux.intel.com>2018-03-04 04:41:51 -0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2018-03-06 06:13:58 -0800
commitf9398daec484c031c37c22f6c67c19c31716c218 (patch)
tree7d1d13545d5485e9b1216e5aa8a7c117444321e8 /meta/recipes-devtools/perl
parent2735e7bfe20a31497a6b975c67ac689eccd5950e (diff)
downloadopenembedded-core-contrib-f9398daec484c031c37c22f6c67c19c31716c218.tar.gz
liberror-perl: inherit ptest-perl
* Enable ptest by inheriting new ptest-perl.bbclass Signed-off-by: Tim Orling <timothy.t.orling@linux.intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/perl')
-rw-r--r--meta/recipes-devtools/perl/liberror-perl_0.17025.bb7
1 files changed, 6 insertions, 1 deletions
diff --git a/meta/recipes-devtools/perl/liberror-perl_0.17025.bb b/meta/recipes-devtools/perl/liberror-perl_0.17025.bb
index 251b13195a..f6dc30d077 100644
--- a/meta/recipes-devtools/perl/liberror-perl_0.17025.bb
+++ b/meta/recipes-devtools/perl/liberror-perl_0.17025.bb
@@ -18,11 +18,16 @@ SRC_URI[sha256sum] = "6c9f474ad3d4fe0cabff6b6be532cb1dd348245986d4a6b600ad921d5c
S = "${WORKDIR}/Error-${PV}"
-inherit cpan
+inherit cpan ptest-perl
do_compile() {
export LIBC="$(find ${STAGING_DIR_TARGET}/${base_libdir}/ -name 'libc-*.so')"
cpan_do_compile
}
+do_install_prepend() {
+ # test requires "-T" (taint) command line option
+ rm -rf ${B}/t/pod-coverage.t
+}
+
BBCLASSEXTEND = "native"