summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/perl
diff options
context:
space:
mode:
authorTim Orling <timothy.t.orling@linux.intel.com>2018-03-04 04:41:52 -0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2018-03-06 06:13:58 -0800
commite88c7fc244c6abe3148f60c8988234342c351dfb (patch)
tree766523f9dcfe759a0f520274f8b3eed940101cc6 /meta/recipes-devtools/perl
parentf9398daec484c031c37c22f6c67c19c31716c218 (diff)
downloadopenembedded-core-contrib-e88c7fc244c6abe3148f60c8988234342c351dfb.tar.gz
liburi-perl: inherit ptest-perl
* Enable ptest by inheriting new ptest-perl.bbclass * Remove t/cwd.t and t/file.t which require "-T" (taint) command line option as they will fail. Signed-off-by: Tim Orling <timothy.t.orling@linux.intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/perl')
-rw-r--r--meta/recipes-devtools/perl/liburi-perl_1.73.bb10
1 files changed, 9 insertions, 1 deletions
diff --git a/meta/recipes-devtools/perl/liburi-perl_1.73.bb b/meta/recipes-devtools/perl/liburi-perl_1.73.bb
index 7cdf6dc61d..49238f3df5 100644
--- a/meta/recipes-devtools/perl/liburi-perl_1.73.bb
+++ b/meta/recipes-devtools/perl/liburi-perl_1.73.bb
@@ -20,11 +20,19 @@ S = "${WORKDIR}/URI-${PV}"
EXTRA_CPANFLAGS = "EXPATLIBPATH=${STAGING_LIBDIR} EXPATINCPATH=${STAGING_INCDIR}"
-inherit cpan
+inherit cpan ptest-perl
do_compile() {
export LIBC="$(find ${STAGING_DIR_TARGET}/${base_libdir}/ -name 'libc-*.so')"
cpan_do_compile
}
+do_install_prepend() {
+ # these tests require "-T" (taint) command line option
+ rm -rf ${B}/t/cwd.t
+ rm -rf ${B}/t/file.t
+}
+
+RDEPENDS_${PN}-ptest += "libtest-needs-perl"
+
BBCLASSEXTEND = "native"