summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/perl
diff options
context:
space:
mode:
authorMingli Yu <mingli.yu@windriver.com>2021-07-06 17:06:08 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2021-07-07 11:38:57 +0100
commita494de43c3ccdcf7af988765ae5c3a95bc20c567 (patch)
tree65ade03e196cdd484a92ef258175d93c03f77873 /meta/recipes-devtools/perl
parent4978f40eb91ec6d76c61d5e0d1e4a98d0d5bb2f7 (diff)
downloadopenembedded-core-contrib-a494de43c3ccdcf7af988765ae5c3a95bc20c567.tar.gz
perl: correct libpth and glibpth
Previouly there is a logic as below used to set libpth in config.sh. libpth='@LIBDIR@ @BASELIBDIR@' But after the below commits introduced, the above logic is dropped. 52f2828314 perl: add a version that builds the recipe using perl-cross, and update to 5.28.1 68552c3532 perl: remove the previous version of the recipe So correct the value of libpth and glibpth to add the dropped logic back to avoid confusing. Before the patch(on 64bits system): # perl -V:libpth libpth='/usr/lib /lib'; After the patch(on 64bits system): # perl -V:libpth libpth='/usr/lib64 /lib64'; Signed-off-by: Mingli Yu <mingli.yu@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/perl')
-rw-r--r--meta/recipes-devtools/perl/perl_5.34.0.bb2
1 files changed, 2 insertions, 0 deletions
diff --git a/meta/recipes-devtools/perl/perl_5.34.0.bb b/meta/recipes-devtools/perl/perl_5.34.0.bb
index 7935a58723..434535c5ee 100644
--- a/meta/recipes-devtools/perl/perl_5.34.0.bb
+++ b/meta/recipes-devtools/perl/perl_5.34.0.bb
@@ -53,6 +53,8 @@ do_configure_class-target() {
-Dsoname=libperl.so.5 \
-Dvendorprefix=${prefix} \
-Darchlibexp=${STAGING_LIBDIR}/perl5/${PV}/${TARGET_ARCH}-linux \
+ -Dlibpth='${libdir} ${base_libdir}' \
+ -Dglibpth='${libdir} ${base_libdir}' \
${PACKAGECONFIG_CONFARGS}
#perl.c uses an ARCHLIB_EXP define to generate compile-time code that