summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/perl
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2011-03-17 22:40:15 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2011-03-23 12:21:16 +0000
commit8ba700a4c593fd52bd01b6272b4c8285a71964f7 (patch)
tree44d6a25cbec8cd3bc32d8df87e54f6529c1572ad /meta/recipes-devtools/perl
parent44359c953a6205a5028483e22b81e9d1691bfd44 (diff)
downloadopenembedded-core-contrib-8ba700a4c593fd52bd01b6272b4c8285a71964f7.tar.gz
perl-native_5.12.2.bb: Fix compliation on ubuntu 11.04-alpha
Ubuntu has moved eglibc to /usr/lib/${arch}-linux-gnu and /lib/${arch}-linux-gnu so we need that to be added to glibpth in Configure. Currently we set LD=ld in environment for recipes inheriting native class. This overrides the LD settings in the Makefiles of perl and it tries to link by calling ld which does not work since its using -l<x> on commandline and ubuntu linker seems not to look into the new location for these libraries. Its better to use gcc for linking here anyway [With tweak from Tom Rini to use CCLD, not LD] Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta/recipes-devtools/perl')
-rw-r--r--meta/recipes-devtools/perl/files/Configure-multilib.patch10
-rw-r--r--meta/recipes-devtools/perl/perl-native_5.12.2.bb4
2 files changed, 10 insertions, 4 deletions
diff --git a/meta/recipes-devtools/perl/files/Configure-multilib.patch b/meta/recipes-devtools/perl/files/Configure-multilib.patch
index d3948a92c0..b561b6ab6f 100644
--- a/meta/recipes-devtools/perl/files/Configure-multilib.patch
+++ b/meta/recipes-devtools/perl/files/Configure-multilib.patch
@@ -1,11 +1,15 @@
---- perl-5.8.7/Configure.orig 2006-01-30 10:50:04.000000000 +0000
-+++ perl-5.8.7/Configure 2006-01-30 10:51:18.000000000 +0000
-@@ -1240,7 +1240,7 @@
+Index: perl-5.12.2/Configure
+===================================================================
+--- perl-5.12.2.orig/Configure
++++ perl-5.12.2/Configure
+@@ -1316,8 +1316,9 @@ loclibpth="/usr/local/lib /opt/local/lib
loclibpth="$loclibpth /opt/gnu/lib /usr/GNU/lib /opt/GNU/lib"
: general looking path for locating libraries
-glibpth="/lib /usr/lib $xlibpth"
+glibpth="/lib /usr/lib /lib64 /usr/lib64 $xlibpth"
glibpth="$glibpth /usr/ccs/lib /usr/ucblib /usr/local/lib"
++test -f /usr/lib/`uname -m`-linux-gnu/libc.so && glibpth="/usr/lib/`uname -m`-linux-gnu $glibpth"
test -f /usr/shlib/libc.so && glibpth="/usr/shlib $glibpth"
test -f /shlib/libc.so && glibpth="/shlib $glibpth"
+ test -d /usr/lib64 && glibpth="$glibpth /lib64 /usr/lib64 /usr/local/lib64"
diff --git a/meta/recipes-devtools/perl/perl-native_5.12.2.bb b/meta/recipes-devtools/perl/perl-native_5.12.2.bb
index 9af7b06e08..c9882a9101 100644
--- a/meta/recipes-devtools/perl/perl-native_5.12.2.bb
+++ b/meta/recipes-devtools/perl/perl-native_5.12.2.bb
@@ -4,7 +4,7 @@ SECTION = "libs"
LICENSE = "Artistic|GPL"
LIC_FILES_CHKSUM = "file://Copying;md5=2b4c6ffbcfcbdee469f02565f253d81a \
file://Artistic;md5=f921793d03cc6d63ec4b15e9be8fd3f8"
-PR = "r7"
+PR = "r8"
LIC_FILES_CHKSUM = "file://Copying;md5=2b4c6ffbcfcbdee469f02565f253d81a \
file://Artistic;md5=f921793d03cc6d63ec4b15e9be8fd3f8"
@@ -28,6 +28,8 @@ S = "${WORKDIR}/perl-${PV}"
inherit native
+export LD="${CCLD}"
+
do_configure () {
./Configure \
-Dcc="${CC}" \