summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/perl/perl_5.34.0.bb
diff options
context:
space:
mode:
authorAlexander Kanavin <alex.kanavin@gmail.com>2021-12-04 08:12:59 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2021-12-06 11:09:47 +0000
commitb9bc216c8d25ad3696c858bf12ebe893b8fe0edd (patch)
tree12037b0bb8af572d654d77b22d011458032ab6e7 /meta/recipes-devtools/perl/perl_5.34.0.bb
parentbf9dc667a1a3c4967fb8f0a18c8bdec4de5a7a1a (diff)
downloadopenembedded-core-contrib-b9bc216c8d25ad3696c858bf12ebe893b8fe0edd.tar.gz
perl: replace a patch with a config option
Instead of patching in LDFLAGS into makefiles, simply append them to 'lddlflags' (perl's keyword for 'linker flags'). See here for upstream discussions: https://github.com/Perl-Toolchain-Gang/ExtUtils-MakeMaker/pull/406 https://github.com/arsv/perl-cross/pull/124 Signed-off-by: Alexander Kanavin <alex@linutronix.de> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/perl/perl_5.34.0.bb')
-rw-r--r--meta/recipes-devtools/perl/perl_5.34.0.bb4
1 files changed, 3 insertions, 1 deletions
diff --git a/meta/recipes-devtools/perl/perl_5.34.0.bb b/meta/recipes-devtools/perl/perl_5.34.0.bb
index 16d45ccff3..a6ae80f07e 100644
--- a/meta/recipes-devtools/perl/perl_5.34.0.bb
+++ b/meta/recipes-devtools/perl/perl_5.34.0.bb
@@ -10,7 +10,6 @@ LIC_FILES_CHKSUM = "file://Copying;md5=5b122a36d0f6dc55279a0ebc69f3c60b \
SRC_URI = "https://www.cpan.org/src/5.0/perl-${PV}.tar.gz;name=perl \
file://perl-rdepends.txt \
- file://0001-ExtUtils-MakeMaker-add-LDFLAGS-when-linking-binary-m.patch \
file://0001-Somehow-this-module-breaks-through-the-perl-wrapper-.patch \
file://errno_ver.diff \
file://native-perlinc.patch \
@@ -59,6 +58,7 @@ do_configure:class-target() {
-Darchlibexp=${STAGING_LIBDIR}/perl5/${PV}/${TARGET_ARCH}-linux \
-Dlibpth='${libdir} ${base_libdir}' \
-Dglibpth='${libdir} ${base_libdir}' \
+ -Alddlflags=' ${LDFLAGS}' \
${PACKAGECONFIG_CONFARGS}
#perl.c uses an ARCHLIB_EXP define to generate compile-time code that
@@ -83,6 +83,7 @@ do_configure:class-nativesdk() {
-Dsoname=libperl.so.5 \
-Dvendorprefix=${prefix} \
-Darchlibexp=${STAGING_LIBDIR}/perl5/${PV}/${TARGET_ARCH}-linux \
+ -Alddlflags=' ${LDFLAGS}' \
${PACKAGECONFIG_CONFARGS}
# See the comment above
@@ -96,6 +97,7 @@ do_configure:class-native() {
-Dsoname=libperl.so.5 \
-Dvendorprefix=${prefix} \
-Ui_xlocale \
+ -Alddlflags=' ${LDFLAGS}' \
${PACKAGECONFIG_CONFARGS}
}