aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/perl/libxml-parser-perl_2.41.bb
diff options
context:
space:
mode:
authorNitin A Kamble <nitin.a.kamble@intel.com>2011-10-18 17:07:54 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2011-10-20 13:07:14 +0100
commit8b96b339b1e3e2b4f58f79bc6fc0c87a18a6c7d3 (patch)
treed6ab1061d17e9844400f748f092cc2a4327ce795 /meta/recipes-devtools/perl/libxml-parser-perl_2.41.bb
parent95e9eb0d5a9c44c52d550b0796eef08f54925205 (diff)
downloadopenembedded-core-contrib-8b96b339b1e3e2b4f58f79bc6fc0c87a18a6c7d3.tar.gz
libxml-parser-perl: upgrade from 2.40 to 2.41
Signed-off-by: Nitin A Kamble <nitin.a.kamble@intel.com>
Diffstat (limited to 'meta/recipes-devtools/perl/libxml-parser-perl_2.41.bb')
-rw-r--r--meta/recipes-devtools/perl/libxml-parser-perl_2.41.bb32
1 files changed, 32 insertions, 0 deletions
diff --git a/meta/recipes-devtools/perl/libxml-parser-perl_2.41.bb b/meta/recipes-devtools/perl/libxml-parser-perl_2.41.bb
new file mode 100644
index 0000000000..caf5704b32
--- /dev/null
+++ b/meta/recipes-devtools/perl/libxml-parser-perl_2.41.bb
@@ -0,0 +1,32 @@
+DESCRIPTION = "XML::Parser - A perl module for parsing XML documents"
+SECTION = "libs"
+LICENSE = "Artistic"
+LIC_FILES_CHKSUM = "file://README;beginline=2;endline=6;md5=c8767d7516229f07b26e42d1cf8b51f1"
+
+DEPENDS += "expat expat-native"
+
+PR = "r0"
+
+SRC_URI = "http://www.cpan.org/modules/by-module/XML/XML-Parser-${PV}.tar.gz"
+SRC_URI[md5sum] = "c320d2ffa459e6cdc6f9f59c1185855e"
+SRC_URI[sha256sum] = "b48197cd2265a26c5f016489f11a7b450d8833cb8b3d6a46ee15975740894de9"
+
+S = "${WORKDIR}/XML-Parser-${PV}"
+
+EXTRA_CPANFLAGS = "EXPATLIBPATH=${STAGING_LIBDIR} EXPATINCPATH=${STAGING_INCDIR}"
+
+inherit cpan
+
+do_compile() {
+ export LIBC="$(find ${STAGING_DIR_TARGET}/${base_libdir}/ -name 'libc-*.so')"
+ cpan_do_compile
+}
+
+do_compile_virtclass-native() {
+ cpan_do_compile
+}
+
+FILES_${PN}-dbg += "${libdir}/perl/vendor_perl/*/auto/XML/Parser/Expat/.debug/"
+
+BBCLASSEXTEND="native"
+