aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/perl/liburi-perl_1.74.bb
diff options
context:
space:
mode:
authorTim Orling <timothy.t.orling@linux.intel.com>2018-05-04 18:36:30 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2018-05-15 10:00:27 +0100
commit346afbee122a3e0642d552cd5b762e6f0b5a7957 (patch)
treef11d84a3f58f4a0152a01634fe259ca640430b82 /meta/recipes-devtools/perl/liburi-perl_1.74.bb
parentf717eeff2d4823163cb72fb79101220cc48b3286 (diff)
downloadopenembedded-core-contrib-346afbee122a3e0642d552cd5b762e6f0b5a7957.tar.gz
liburi-perl: upgrade 1.73 -> 1.74
Upstream release notes: Changes for version 1.74 - 2018-04-22 avoid 'uninitialized' warning in URI::File when host has no domain name set (PR#53, thanks Shoichi Kaji!) Signed-off-by: Tim Orling <timothy.t.orling@linux.intel.com> Signed-off-by: Ross Burton <ross.burton@intel.com>
Diffstat (limited to 'meta/recipes-devtools/perl/liburi-perl_1.74.bb')
-rw-r--r--meta/recipes-devtools/perl/liburi-perl_1.74.bb38
1 files changed, 38 insertions, 0 deletions
diff --git a/meta/recipes-devtools/perl/liburi-perl_1.74.bb b/meta/recipes-devtools/perl/liburi-perl_1.74.bb
new file mode 100644
index 0000000000..a7cfa0fbe3
--- /dev/null
+++ b/meta/recipes-devtools/perl/liburi-perl_1.74.bb
@@ -0,0 +1,38 @@
+SUMMARY = "Perl module to manipulate and access URI strings"
+DESCRIPTION = "This package contains the URI.pm module with friends. \
+The module implements the URI class. URI objects can be used to access \
+and manipulate the various components that make up these strings."
+
+HOMEPAGE = "http://search.cpan.org/dist/URI/"
+SECTION = "libs"
+LICENSE = "Artistic-1.0 | GPL-1.0+"
+
+LIC_FILES_CHKSUM = "file://LICENSE;md5=c453e94fae672800f83bc1bd7a38b53f"
+
+DEPENDS += "perl"
+
+SRC_URI = "http://www.cpan.org/authors/id/E/ET/ETHER/URI-${PV}.tar.gz"
+
+SRC_URI[md5sum] = "892f7183b178af40f205ba37128225db"
+SRC_URI[sha256sum] = "a9c254f45f89cb1dd946b689dfe433095404532a4543bdaab0b71ce0fdcdd53d"
+
+S = "${WORKDIR}/URI-${PV}"
+
+EXTRA_CPANFLAGS = "EXPATLIBPATH=${STAGING_LIBDIR} EXPATINCPATH=${STAGING_INCDIR}"
+
+inherit cpan ptest-perl
+
+do_compile() {
+ export LIBC="$(find ${STAGING_DIR_TARGET}/${base_libdir}/ -name 'libc-*.so')"
+ cpan_do_compile
+}
+
+do_install_prepend() {
+ # these tests require "-T" (taint) command line option
+ rm -rf ${B}/t/cwd.t
+ rm -rf ${B}/t/file.t
+}
+
+RDEPENDS_${PN}-ptest += "libtest-needs-perl"
+
+BBCLASSEXTEND = "native"