aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/perl/liburi-perl_1.73.bb
diff options
context:
space:
mode:
authorTim Orling <timothy.t.orling@linux.intel.com>2018-01-23 21:26:43 -0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2018-01-26 13:07:22 +0000
commit35141b582056f2cae47edba791efe1dcfa23f6e0 (patch)
treeb5d7870d4def4cee7e1ab7ef9ecc601b75fdf830 /meta/recipes-devtools/perl/liburi-perl_1.73.bb
parent215d5677004537fc190b5381157ac8b94db6d7e8 (diff)
downloadopenembedded-core-contrib-35141b582056f2cae47edba791efe1dcfa23f6e0.tar.gz
liburi-perl: upgrade 1.72 -> 1.73
Changes: 1.73 2018-01-09 06:42:51Z - Update documentation for URI::_punycode (GH Issue #45) Signed-off-by: Tim Orling <timothy.t.orling@linux.intel.com> Signed-off-by: Ross Burton <ross.burton@intel.com>
Diffstat (limited to 'meta/recipes-devtools/perl/liburi-perl_1.73.bb')
-rw-r--r--meta/recipes-devtools/perl/liburi-perl_1.73.bb30
1 files changed, 30 insertions, 0 deletions
diff --git a/meta/recipes-devtools/perl/liburi-perl_1.73.bb b/meta/recipes-devtools/perl/liburi-perl_1.73.bb
new file mode 100644
index 0000000000..7cdf6dc61d
--- /dev/null
+++ b/meta/recipes-devtools/perl/liburi-perl_1.73.bb
@@ -0,0 +1,30 @@
+SUMMARY = "Perl module to manipulate and access URI strings"
+DESCRIPTION = "This package contains the URI.pm module with friends. \
+The module implements the URI class. URI objects can be used to access \
+and manipulate the various components that make up these strings."
+
+HOMEPAGE = "http://search.cpan.org/dist/URI/"
+SECTION = "libs"
+LICENSE = "Artistic-1.0 | GPL-1.0+"
+
+LIC_FILES_CHKSUM = "file://LICENSE;md5=c453e94fae672800f83bc1bd7a38b53f"
+
+DEPENDS += "perl"
+
+SRC_URI = "http://www.cpan.org/authors/id/E/ET/ETHER/URI-${PV}.tar.gz"
+
+SRC_URI[md5sum] = "37d44a08e599aa945b32a9434ffe00a5"
+SRC_URI[sha256sum] = "cca7ab4a6f63f3ccaacae0f2e1337e8edf84137e73f18548ec7d659f23efe413"
+
+S = "${WORKDIR}/URI-${PV}"
+
+EXTRA_CPANFLAGS = "EXPATLIBPATH=${STAGING_LIBDIR} EXPATINCPATH=${STAGING_INCDIR}"
+
+inherit cpan
+
+do_compile() {
+ export LIBC="$(find ${STAGING_DIR_TARGET}/${base_libdir}/ -name 'libc-*.so')"
+ cpan_do_compile
+}
+
+BBCLASSEXTEND = "native"