aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/pax-utils/pax-utils_1.1.5.bb
diff options
context:
space:
mode:
authorAlexander Kanavin <alexander.kanavin@linux.intel.com>2016-02-24 17:36:35 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2016-02-28 11:32:40 +0000
commit51d6dffb8fb7cbad459c8e9198c8dd94244a8964 (patch)
tree01c803419238e30ccdc6607ffbd9e6f4b80f60b1 /meta/recipes-devtools/pax-utils/pax-utils_1.1.5.bb
parent6f202d8532087306bace2ba4e5009ed25a814cb2 (diff)
downloadopenembedded-core-contrib-51d6dffb8fb7cbad459c8e9198c8dd94244a8964.tar.gz
pax-utils: update to 1.1.5
Remove fix-configure-failure.patch, the problem has been fixed upstream. Add README to the list of files that must be created before configuring the build. Signed-off-by: Alexander Kanavin <alexander.kanavin@linux.intel.com> Signed-off-by: Ross Burton <ross.burton@intel.com>
Diffstat (limited to 'meta/recipes-devtools/pax-utils/pax-utils_1.1.5.bb')
-rw-r--r--meta/recipes-devtools/pax-utils/pax-utils_1.1.5.bb35
1 files changed, 35 insertions, 0 deletions
diff --git a/meta/recipes-devtools/pax-utils/pax-utils_1.1.5.bb b/meta/recipes-devtools/pax-utils/pax-utils_1.1.5.bb
new file mode 100644
index 0000000000..a887c037d3
--- /dev/null
+++ b/meta/recipes-devtools/pax-utils/pax-utils_1.1.5.bb
@@ -0,0 +1,35 @@
+SUMMARY = "Security-focused ELF files checking tool"
+DESCRIPTION = "This is a small set of various PaX aware and related \
+utilities for ELF binaries. It can check ELF binary files and running \
+processes for issues that might be relevant when using ELF binaries \
+along with PaX, such as non-PIC code or executable stack and heap."
+HOMEPAGE = "http://www.gentoo.org/proj/en/hardened/pax-utils.xml"
+LICENSE = "GPLv2+"
+LIC_FILES_CHKSUM = "file://COPYING;md5=eb723b61539feef013de476e68b5c50a"
+
+SRC_URI = "http://gentoo.osuosl.org/distfiles/pax-utils-${PV}.tar.xz \
+"
+
+SRC_URI[md5sum] = "bc3614322eaf88f167a608ae85d6b207"
+SRC_URI[sha256sum] = "2945b3e4df2e0dc95800bfbd3d88ab2243b2ee4ff064bbfc75734f6d9d986a89"
+
+RDEPENDS_${PN} += "bash"
+
+do_configure_prepend() {
+ touch ${S}/NEWS ${S}/AUTHORS ${S}/ChangeLog ${S}/README
+}
+
+do_install() {
+ oe_runmake PREFIX=${D}${prefix} DESTDIR=${D} install
+}
+
+BBCLASSEXTEND = "native"
+
+inherit autotools pkgconfig
+
+PACKAGECONFIG ??= "${@bb.utils.contains('DISTRO_FEATURES', 'largefile', 'largefile', '', d)} \
+"
+PACKAGECONFIG[libcap] = "--with-caps, --without-caps, libcap"
+PACKAGECONFIG[libseccomp] = "--with-seccomp, --without-seccomp, libseccomp"
+PACKAGECONFIG[largefile] = "--enable-largefile,--disable-largefile,,"
+PACKAGECONFIG[pyelftools] = "--with-python, --without-python,, pyelftools"