summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/opkg
diff options
context:
space:
mode:
authorYi Zhao <yi.zhao@windriver.com>2020-05-07 11:24:32 +0800
committerSteve Sakoman <steve@sakoman.com>2020-05-11 06:14:33 -1000
commit174c27e4edea0af92f60779cf3f63d21f6bce6fe (patch)
treeadfb71ee9b4eab163043cc08138f8d6adb3e4c7a /meta/recipes-devtools/opkg
parent8587149c49dd8d1e1a0a0b5cf81e458bfa88547e (diff)
downloadopenembedded-core-contrib-174c27e4edea0af92f60779cf3f63d21f6bce6fe.tar.gz
opkg-keyrings: check if opkg-key exists before run postinst
By default, the opkg-key command is not included in pokg package because it is only installed when gpg support is enabled. We'd better check if it exists before run 'opkg-key populate' in pkg_postinst. Signed-off-by: Yi Zhao <yi.zhao@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org> Signed-off-by: Steve Sakoman <steve@sakoman.com>
Diffstat (limited to 'meta/recipes-devtools/opkg')
-rw-r--r--meta/recipes-devtools/opkg/opkg-keyrings_1.0.bb5
1 files changed, 4 insertions, 1 deletions
diff --git a/meta/recipes-devtools/opkg/opkg-keyrings_1.0.bb b/meta/recipes-devtools/opkg/opkg-keyrings_1.0.bb
index a20e316a3d..07e2402545 100644
--- a/meta/recipes-devtools/opkg/opkg-keyrings_1.0.bb
+++ b/meta/recipes-devtools/opkg/opkg-keyrings_1.0.bb
@@ -36,5 +36,8 @@ FILES_${PN} = "${datadir}/opkg/keyrings"
RDEPENDS_${PN} = "opkg"
pkg_postinst_ontarget_${PN} () {
-opkg-key populate
+ if test -x ${bindir}/opkg-key
+ then
+ ${bindir}/opkg-key populate
+ fi
}