summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/opkg
diff options
context:
space:
mode:
authorChen Qi <Qi.Chen@windriver.com>2021-11-01 22:25:28 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2021-11-03 10:12:01 +0000
commitd181f8c3798165808b1f529650ca47aae7730d9d (patch)
tree4ae328bb45a45783b9a140bf2af07c3c3a67822b /meta/recipes-devtools/opkg
parent3bb1cb476dbad1037522970af9afd69691a7033c (diff)
downloadopenembedded-core-contrib-d181f8c3798165808b1f529650ca47aae7730d9d.tar.gz
opkg: use oe.qa.add_message istead of package_qa_add_message
Since the following commit, package_qa_add_message is no longer available, use oe.qa.add_message instead. """ commit f0ad152ef4cc15c042bc9eeefb6af096d054b220 Author: Mike Crowe <mac@mcrowe.com> Date: Fri Oct 15 15:39:53 2021 +0100 lib/oe/qa,insane: Move extra error handling functions to library Extract package_qa_write_error, package_qa_handle_error and package_qa_add_message functions from insane.bbclass to lib/oe/qa.py and drop the package_qa_ prefixes. ... """ Signed-off-by: Chen Qi <Qi.Chen@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/opkg')
-rw-r--r--meta/recipes-devtools/opkg/opkg_0.4.5.bb2
1 files changed, 1 insertions, 1 deletions
diff --git a/meta/recipes-devtools/opkg/opkg_0.4.5.bb b/meta/recipes-devtools/opkg/opkg_0.4.5.bb
index ef18ccf63a..f5c7d11191 100644
--- a/meta/recipes-devtools/opkg/opkg_0.4.5.bb
+++ b/meta/recipes-devtools/opkg/opkg_0.4.5.bb
@@ -67,7 +67,7 @@ def package_qa_check_openssl_deprecation (package, d, messages):
pkgconfig = (d.getVar("PACKAGECONFIG") or "").split()
if pkgconfig and 'openssl' in pkgconfig:
- package_qa_add_message(messages, 'openssl-deprecation', '"openssl" in opkg.bb PACKAGECONFIG. Feed signature checking with OpenSSL will be deprecated in the next opkg release. Consider using GPG checking instead.')
+ oe.qa.add_message(messages, 'openssl-deprecation', '"openssl" in opkg.bb PACKAGECONFIG. Feed signature checking with OpenSSL will be deprecated in the next opkg release. Consider using GPG checking instead.')
sane = False
return sane