aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/opkg
diff options
context:
space:
mode:
authorPaul Barker <paul@paulbarker.me.uk>2014-12-19 17:35:29 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2015-02-03 14:53:55 +0000
commitd07c9addee2a97af3e8fb0985d2f0c00323e5d3f (patch)
tree3df813728925c5d17d9a10b6ab80587bb60f7428 /meta/recipes-devtools/opkg
parentd1373d46421443cf5f4c639d8108a0a72cc69744 (diff)
downloadopenembedded-core-contrib-d07c9addee2a97af3e8fb0985d2f0c00323e5d3f.tar.gz
opkg-collateral: Simplify source files
Instead of having the source files 'opkg.conf.comments', 'dest' and 'src', we simply have one 'opkg.conf' file containing all the necessary configuration. This does mean that replacing 'src' in a bbappend to define distro-specific package feeds is no longer supported, but these feed configurations should be packaged separately from the rest of the opkg configuration anyway so that things can be updated independently. The best recipe to use for managing feed configs is currently distro-feed-config in the meta-oe layer. (From OE-Core rev: f7c591df37493e8f3cde9c19bb0d1edc370eca1c) Signed-off-by: Paul Barker <paul@paulbarker.me.uk> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/opkg')
-rw-r--r--meta/recipes-devtools/opkg/opkg-collateral.bb7
-rw-r--r--meta/recipes-devtools/opkg/opkg-collateral/dest1
-rw-r--r--meta/recipes-devtools/opkg/opkg-collateral/opkg.conf (renamed from meta/recipes-devtools/opkg/opkg-collateral/opkg.conf.comments)2
-rw-r--r--meta/recipes-devtools/opkg/opkg-collateral/src0
4 files changed, 3 insertions, 7 deletions
diff --git a/meta/recipes-devtools/opkg/opkg-collateral.bb b/meta/recipes-devtools/opkg/opkg-collateral.bb
index 0cf6b8be40..f080dfc3ab 100644
--- a/meta/recipes-devtools/opkg/opkg-collateral.bb
+++ b/meta/recipes-devtools/opkg/opkg-collateral.bb
@@ -4,17 +4,12 @@ LICENSE = "MIT"
LIC_FILES_CHKSUM = "file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420"
PR = "r2"
-SRC_URI = "file://opkg.conf.comments \
- file://dest \
- file://src "
+SRC_URI = "file://opkg.conf"
S = "${WORKDIR}"
OPKGLIBDIR = "${localstatedir}/lib"
do_compile () {
- cat ${WORKDIR}/opkg.conf.comments >${WORKDIR}/opkg.conf
- cat ${WORKDIR}/src >>${WORKDIR}/opkg.conf
- cat ${WORKDIR}/dest >>${WORKDIR}/opkg.conf
echo "option lists_dir ${OPKGLIBDIR}/opkg" >>${WORKDIR}/opkg.conf
}
diff --git a/meta/recipes-devtools/opkg/opkg-collateral/dest b/meta/recipes-devtools/opkg/opkg-collateral/dest
deleted file mode 100644
index 088ca403da..0000000000
--- a/meta/recipes-devtools/opkg/opkg-collateral/dest
+++ /dev/null
@@ -1 +0,0 @@
-dest root /
diff --git a/meta/recipes-devtools/opkg/opkg-collateral/opkg.conf.comments b/meta/recipes-devtools/opkg/opkg-collateral/opkg.conf
index e1fdada9b5..c2e9e92f95 100644
--- a/meta/recipes-devtools/opkg/opkg-collateral/opkg.conf.comments
+++ b/meta/recipes-devtools/opkg/opkg-collateral/opkg.conf
@@ -24,3 +24,5 @@
# Offline mode (for use in constructing flash images offline)
#option offline_root target
+# Default destination for installed packages
+dest root /
diff --git a/meta/recipes-devtools/opkg/opkg-collateral/src b/meta/recipes-devtools/opkg/opkg-collateral/src
deleted file mode 100644
index e69de29bb2..0000000000
--- a/meta/recipes-devtools/opkg/opkg-collateral/src
+++ /dev/null