summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/opkg
diff options
context:
space:
mode:
authorRichard Purdie <richard.purdie@linuxfoundation.org>2021-11-04 14:01:41 +0000
committerAnuj Mittal <anuj.mittal@intel.com>2021-11-09 09:28:55 +0800
commit0ed0fd99153dd8a4560b6fbbbaa0decc60f79c5a (patch)
tree79951d059af245d41b266c7bc7c419d003f5a50c /meta/recipes-devtools/opkg
parent38d613df4854d269493d019d24606161d49b4659 (diff)
downloadopenembedded-core-contrib-0ed0fd99153dd8a4560b6fbbbaa0decc60f79c5a.tar.gz
opkg: Fix poor operator combination choice
Combining :append with += rarely makes sense. Improve it to use the standard format (and tweak the implied spacing). Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org> (cherry picked from commit 768766dc007ebe9b4bc38d425584be03fbdb98c1) Signed-off-by: Anuj Mittal <anuj.mittal@intel.com>
Diffstat (limited to 'meta/recipes-devtools/opkg')
-rw-r--r--meta/recipes-devtools/opkg/opkg_0.4.5.bb2
1 files changed, 1 insertions, 1 deletions
diff --git a/meta/recipes-devtools/opkg/opkg_0.4.5.bb b/meta/recipes-devtools/opkg/opkg_0.4.5.bb
index ef18ccf63a..8152fa0658 100644
--- a/meta/recipes-devtools/opkg/opkg_0.4.5.bb
+++ b/meta/recipes-devtools/opkg/opkg_0.4.5.bb
@@ -60,7 +60,7 @@ do_install_ptest () {
sed -i -e '/@PYTHONPATH=. $(PYTHON) $^/a\\t@if [ "$$?" != "0" ];then echo "FAIL:"$^;else echo "PASS:"$^;fi' ${D}${PTEST_PATH}/tests/Makefile
}
-WARN_QA:append += "openssl-deprecation"
+WARN_QA:append = " openssl-deprecation"
QAPKGTEST[openssl-deprecation] = "package_qa_check_openssl_deprecation"
def package_qa_check_openssl_deprecation (package, d, messages):
sane = True