aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/opkg/opkg-0.1.8
diff options
context:
space:
mode:
authorRobert Yang <liezhi.yang@windriver.com>2012-06-08 07:39:43 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-06-15 15:09:17 +0100
commit316fac638646a50149f36ec4687b5a2a6d2e83b1 (patch)
treece5d5894207c6ac96e2509be8d7767ca230d1d7c /meta/recipes-devtools/opkg/opkg-0.1.8
parent7f007994cbc5f188439ad2b26f60dbcc1c2763bd (diff)
downloadopenembedded-core-contrib-316fac638646a50149f36ec4687b5a2a6d2e83b1.tar.gz
opkg 0.1.8: do_fetch failed since no checksum specified
* We use meta/recipes-devtools/opkg/opkg_svn.bb by default, the opkg_0.1.8.bb failed since no checksum specified. * The add_vercmp.patch in both opkg/ and opkg-0.1.8/, remove the one in opkg-0.1.8/ This patch doesn't impact the output, so I think that we don't have to increment the PR. [YOCTO #2498] Signed-off-by: Robert Yang <liezhi.yang@windriver.com>
Diffstat (limited to 'meta/recipes-devtools/opkg/opkg-0.1.8')
-rw-r--r--meta/recipes-devtools/opkg/opkg-0.1.8/add_vercmp.patch36
1 files changed, 0 insertions, 36 deletions
diff --git a/meta/recipes-devtools/opkg/opkg-0.1.8/add_vercmp.patch b/meta/recipes-devtools/opkg/opkg-0.1.8/add_vercmp.patch
deleted file mode 100644
index c3396d5890..0000000000
--- a/meta/recipes-devtools/opkg/opkg-0.1.8/add_vercmp.patch
+++ /dev/null
@@ -1,36 +0,0 @@
-Upstream-Status: Inappropriate [other]
-
-Index: trunk/libopkg/opkg.c
-===================================================================
---- trunk.orig/libopkg/opkg.c 2010-01-26 20:32:19.000000000 +0000
-+++ trunk/libopkg/opkg.c 2010-01-26 20:40:34.000000000 +0000
-@@ -876,3 +876,18 @@
-
- return ret;
- }
-+
-+int
-+opkg_compare_versions (const char *ver1, const char *ver2)
-+{
-+ pkg_t *pkg1, *pkg2;
-+
-+ pkg1 = pkg_new();
-+ pkg2 = pkg_new();
-+
-+ parse_version(pkg1, ver1);
-+ parse_version(pkg2, ver2);
-+
-+ return pkg_compare_versions(pkg1, pkg2);
-+}
-+
-Index: trunk/libopkg/opkg.h
-===================================================================
---- trunk.orig/libopkg/opkg.h 2010-01-26 20:32:19.000000000 +0000
-+++ trunk/libopkg/opkg.h 2010-01-26 20:35:19.000000000 +0000
-@@ -58,4 +58,6 @@
-
- int opkg_repository_accessibility_check(void);
-
-+int opkg_compare_versions (const char *ver1, const char *ver2);
-+
- #endif /* OPKG_H */