aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/opensp
diff options
context:
space:
mode:
authorZhai Edwin <edwin.zhai@intel.com>2011-09-13 17:02:51 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2011-09-13 17:03:54 +0100
commita5aeb873b943300e18493031ffa9e9f8ab56c2d2 (patch)
treef55f49f1d3b0dd691ebc727d7d00b48903138f71 /meta/recipes-devtools/opensp
parent8fce8180c802ad187c4df44c17207bfb026ce6c7 (diff)
downloadopenembedded-core-contrib-a5aeb873b943300e18493031ffa9e9f8ab56c2d2.tar.gz
opensp: Fix hard path in native nsgmls.
This relocation issues caused following bug and introduce one partial fix bb024d: [YOCTO #1440] But the environment val hacking is not working all the time, as nsgmsl may append wrong path in some case. This fix use search directory "-D" as solution. And more important, change the iputils' way to make doc: Use the sysid in current directory instead of parent directory, as "../" is also appended to the search directory then lead searching failure. Signed-off-by: Zhai Edwin <edwin.zhai@intel.com> CC: Saul Would <sgw@linux.intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/opensp')
-rw-r--r--meta/recipes-devtools/opensp/opensp_1.5.bb9
1 files changed, 8 insertions, 1 deletions
diff --git a/meta/recipes-devtools/opensp/opensp_1.5.bb b/meta/recipes-devtools/opensp/opensp_1.5.bb
index a402d11c72..d692137452 100644
--- a/meta/recipes-devtools/opensp/opensp_1.5.bb
+++ b/meta/recipes-devtools/opensp/opensp_1.5.bb
@@ -5,7 +5,7 @@ SECTION = "libs"
LICENSE = "BSD"
LIC_FILES_CHKSUM = "file://COPYING;md5=641ff1e4511f0a87044ad42f87cb1045"
-PR = "r1"
+PR = "r2"
# At -Os it encounters calls to some inline functions which are then
# not found in any other objects with gcc 4.5
@@ -42,6 +42,13 @@ do_install_append() {
ln -sf osx sgml2xml
}
+do_install_append_virtclass-native() {
+ for util in nsgmls sgmlnorm spam spcat spent sx; do
+ create_cmdline_wrapper ${D}/${bindir}/$util \
+ -D ${sysconfdir}/sgml
+ done
+}
+
FILES_${PN} += "${datadir}/OpenSP/"
BBCLASSEXTEND = "native"