aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/openjade
diff options
context:
space:
mode:
authorScott Garman <scott.a.garman@intel.com>2011-02-09 16:00:08 -0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2011-02-12 00:30:28 +0000
commite56f63a2843e5a7d70fd60e0aaed4d962a277da7 (patch)
tree1b1d1bd2cab1a531e5f5d3a476fd75be7e7d6a7e /meta/recipes-devtools/openjade
parent293b023361580cdf41cf8aa0d8e96fd9c380e424 (diff)
downloadopenembedded-core-contrib-e56f63a2843e5a7d70fd60e0aaed4d962a277da7.tar.gz
openjade: fix build issues
* Recipe is now -native only * Fix install failure due to missing install path * Removed recipe cruft that was not needed, simplifying it * Removed unnecessary patches * Improved patch comment for makefile.patch Signed-off-by: Scott Garman <scott.a.garman@intel.com>
Diffstat (limited to 'meta/recipes-devtools/openjade')
-rw-r--r--meta/recipes-devtools/openjade/openjade-1.3.2/autoconf.patch173
-rw-r--r--meta/recipes-devtools/openjade/openjade-1.3.2/configure.patch68
-rw-r--r--meta/recipes-devtools/openjade/openjade-1.3.2/makefile.patch3
-rw-r--r--meta/recipes-devtools/openjade/openjade-1.3.2/oj-native-libosp-fix.patch15
-rw-r--r--meta/recipes-devtools/openjade/openjade-native_1.3.2.bb (renamed from meta/recipes-devtools/openjade/openjade_1.3.2.bb)26
5 files changed, 8 insertions, 277 deletions
diff --git a/meta/recipes-devtools/openjade/openjade-1.3.2/autoconf.patch b/meta/recipes-devtools/openjade/openjade-1.3.2/autoconf.patch
deleted file mode 100644
index fe8df5bb4a..0000000000
--- a/meta/recipes-devtools/openjade/openjade-1.3.2/autoconf.patch
+++ /dev/null
@@ -1,173 +0,0 @@
-Patch obtained from OpenEmbedded.
-
-Signed-off-by: Scott Garman <scott.a.garman@intel.com>
--- config/acinclude.m4
-+++ config/acinclude.m4 2002/04/08 23:13:37
-@@ -0,0 +1,61 @@
-+dnl Configure-time switch with default
-+dnl
-+dnl Each switch defines an --enable-FOO and --disable-FOO option in
-+dnl the resulting configure script.
-+dnl
-+dnl Usage:
-+dnl SMR_SWITCH(name, description, default, pos-def, neg-def)
-+dnl
-+dnl where:
-+dnl
-+dnl name name of switch; generates --enable-name & --disable-name
-+dnl options
-+dnl description help string is set to this prefixed by "enable" or
-+dnl "disable", whichever is the non-default value
-+dnl default either "on" or "off"; specifies default if neither
-+dnl --enable-name nor --disable-name is specified
-+dnl pos-def a symbol to AC_DEFINE if switch is on (optional)
-+dnl neg-def a symbol to AC_DEFINE if switch is off (optional)
-+dnl
-+AC_DEFUN(SMR_SWITCH, [
-+ AC_MSG_CHECKING(whether to enable $2)
-+ AC_ARG_ENABLE(
-+ $1,
-+ ifelse($3, on,
-+ [ --disable-[$1] disable [$2]],
-+ [ --enable-[$1] enable [$2]]),
-+ [ if test "$enableval" = yes; then
-+ AC_MSG_RESULT(yes)
-+ ifelse($4, , , AC_DEFINE($4))
-+ else
-+ AC_MSG_RESULT(no)
-+ ifelse($5, , , AC_DEFINE($5))
-+ fi ],
-+ ifelse($3, on,
-+ [ AC_MSG_RESULT(yes)
-+ ifelse($4, , , AC_DEFINE($4)) ],
-+ [ AC_MSG_RESULT(no)
-+ ifelse($5, , , AC_DEFINE($5))]))])
-+
-+dnl
-+dnl Examine size_t and define SIZE_T_IS_UINT, if size_t is an unsigned int
-+dnl
-+AC_DEFUN(OJ_SIZE_T_IS_UINT,[
-+ AC_REQUIRE([AC_TYPE_SIZE_T])
-+ AC_MSG_CHECKING(whether size_t is unsigned int)
-+ ac_cv_size_t_is_uint=no
-+ AC_LANG_SAVE
-+ AC_LANG_CPLUSPLUS
-+ AC_TRY_COMPILE([#include <unistd.h>
-+
-+ template<class T> class foo { };
-+
-+ ], [
-+ foo<size_t> x;
-+ foo<unsigned int> y;
-+ x = y;
-+ ],ac_cv_size_t_is_uint=yes)
-+ AC_LANG_RESTORE
-+ AC_MSG_RESULT($ac_cv_size_t_is_uint)
-+ test "$ac_cv_size_t_is_uint" = "yes" && AC_DEFINE(SIZE_T_IS_UINT)
-+])
-Index: openjade-1.3.2/config/acinclude.m4
-===================================================================
---- openjade-1.3.2.orig/config/acinclude.m4
-+++ openjade-1.3.2/config/acinclude.m4
-@@ -1,3 +1,64 @@
-+dnl Configure-time switch with default
-+dnl
-+dnl Each switch defines an --enable-FOO and --disable-FOO option in
-+dnl the resulting configure script.
-+dnl
-+dnl Usage:
-+dnl SMR_SWITCH(name, description, default, pos-def, neg-def)
-+dnl
-+dnl where:
-+dnl
-+dnl name name of switch; generates --enable-name & --disable-name
-+dnl options
-+dnl description help string is set to this prefixed by "enable" or
-+dnl "disable", whichever is the non-default value
-+dnl default either "on" or "off"; specifies default if neither
-+dnl --enable-name nor --disable-name is specified
-+dnl pos-def a symbol to AC_DEFINE if switch is on (optional)
-+dnl neg-def a symbol to AC_DEFINE if switch is off (optional)
-+dnl
-+AC_DEFUN(SMR_SWITCH, [
-+ AC_MSG_CHECKING(whether to enable $2)
-+ AC_ARG_ENABLE(
-+ $1,
-+ ifelse($3, on,
-+ [ --disable-[$1] disable [$2]],
-+ [ --enable-[$1] enable [$2]]),
-+ [ if test "$enableval" = yes; then
-+ AC_MSG_RESULT(yes)
-+ ifelse($4, , , AC_DEFINE($4))
-+ else
-+ AC_MSG_RESULT(no)
-+ ifelse($5, , , AC_DEFINE($5))
-+ fi ],
-+ ifelse($3, on,
-+ [ AC_MSG_RESULT(yes)
-+ ifelse($4, , , AC_DEFINE($4)) ],
-+ [ AC_MSG_RESULT(no)
-+ ifelse($5, , , AC_DEFINE($5))]))])
-+
-+dnl
-+dnl Examine size_t and define SIZE_T_IS_UINT, if size_t is an unsigned int
-+dnl
-+AC_DEFUN(OJ_SIZE_T_IS_UINT,[
-+ AC_REQUIRE([AC_TYPE_SIZE_T])
-+ AC_MSG_CHECKING(whether size_t is unsigned int)
-+ ac_cv_size_t_is_uint=no
-+ AC_LANG_SAVE
-+ AC_LANG_CPLUSPLUS
-+ AC_TRY_COMPILE([#include <unistd.h>
-+
-+ template<class T> class foo { };
-+
-+ ], [
-+ foo<size_t> x;
-+ foo<unsigned int> y;
-+ x = y;
-+ ],ac_cv_size_t_is_uint=yes)
-+ AC_LANG_RESTORE
-+ AC_MSG_RESULT($ac_cv_size_t_is_uint)
-+ test "$ac_cv_size_t_is_uint" = "yes" && AC_DEFINE(SIZE_T_IS_UINT)
-+])
- dnl
- dnl Examine size_t and define SIZE_T_IS_UINT, if size_t is an unsigned int
- dnl
-Index: openjade-1.3.2/config/aclocal.m4
-===================================================================
---- openjade-1.3.2.orig/config/aclocal.m4
-+++ openjade-1.3.2/config/aclocal.m4
-@@ -3352,7 +3352,7 @@ dnl Each switch defines an --enable-FOO
- dnl the resulting configure script.
- dnl
- dnl Usage:
--dnl smr_SWITCH(name, description, default, pos-def, neg-def)
-+dnl SMR_SWITCH(name, description, default, pos-def, neg-def)
- dnl
- dnl where:
- dnl
-@@ -3365,7 +3365,7 @@ dnl --enable-name nor --disa
- dnl pos-def a symbol to AC_DEFINE if switch is on (optional)
- dnl neg-def a symbol to AC_DEFINE if switch is off (optional)
- dnl
--AC_DEFUN(smr_SWITCH, [
-+AC_DEFUN(SMR_SWITCH, [
- AC_MSG_CHECKING(whether to enable $2)
- AC_ARG_ENABLE(
- $1,
-Index: openjade-1.3.2/config/configure.in
-===================================================================
---- openjade-1.3.2.orig/config/configure.in
-+++ openjade-1.3.2/config/configure.in
-@@ -243,8 +243,8 @@ AC_ARG_ENABLE(http,
- dnl
- dnl optional backends
- dnl
--smr_SWITCH(mif, support for FrameMaker MIF output, on, JADE_MIF, DUMMY)
--smr_SWITCH(html, support for HTML+CSS output, on, JADE_HTML, DUMMY)
-+SMR_SWITCH(mif, support for FrameMaker MIF output, on, JADE_MIF, DUMMY)
-+SMR_SWITCH(html, support for HTML+CSS output, on, JADE_HTML, DUMMY)
-
-
- dnl
diff --git a/meta/recipes-devtools/openjade/openjade-1.3.2/configure.patch b/meta/recipes-devtools/openjade/openjade-1.3.2/configure.patch
deleted file mode 100644
index 2dcaa4d9e6..0000000000
--- a/meta/recipes-devtools/openjade/openjade-1.3.2/configure.patch
+++ /dev/null
@@ -1,68 +0,0 @@
-Patch obtained from OpenEmbedded.
-
-Signed-off-by: Scott Garman <scott.a.garman@intel.com>
---- /dev/null 2003-09-23 18:19:32.000000000 -0400
-+++ openjade-1.3.2/config/acinclude.m4 2004-01-20 14:39:20.000000000 -0500
-@@ -0,0 +1,62 @@
-+dnl
-+dnl Examine size_t and define SIZE_T_IS_UINT, if size_t is an unsigned int
-+dnl
-+AC_DEFUN(OJ_SIZE_T_IS_UINT,[
-+ AC_REQUIRE([AC_TYPE_SIZE_T])
-+ AC_MSG_CHECKING(whether size_t is unsigned int)
-+ ac_cv_size_t_is_uint=no
-+ AC_LANG_SAVE
-+ AC_LANG_CPLUSPLUS
-+ AC_TRY_COMPILE([#include <unistd.h>
-+
-+ template<class T> class foo { };
-+
-+ ], [
-+ foo<size_t> x;
-+ foo<unsigned int> y;
-+ x = y;
-+ ],ac_cv_size_t_is_uint=yes)
-+ AC_LANG_RESTORE
-+ AC_MSG_RESULT($ac_cv_size_t_is_uint)
-+ test "$ac_cv_size_t_is_uint" = "yes" && AC_DEFINE(SIZE_T_IS_UINT)
-+])
-+
-+dnl Configure-time switch with default
-+dnl
-+dnl Each switch defines an --enable-FOO and --disable-FOO option in
-+dnl the resulting configure script.
-+dnl
-+dnl Usage:
-+dnl smr_SWITCH(name, description, default, pos-def, neg-def)
-+dnl
-+dnl where:
-+dnl
-+dnl name name of switch; generates --enable-name & --disable-name
-+dnl options
-+dnl description help string is set to this prefixed by "enable" or
-+dnl "disable", whichever is the non-default value
-+dnl default either "on" or "off"; specifies default if neither
-+dnl --enable-name nor --disable-name is specified
-+dnl pos-def a symbol to AC_DEFINE if switch is on (optional)
-+dnl neg-def a symbol to AC_DEFINE if switch is off (optional)
-+dnl
-+AC_DEFUN(smr_SWITCH, [
-+ AC_MSG_CHECKING(whether to enable $2)
-+ AC_ARG_ENABLE(
-+ $1,
-+ ifelse($3, on,
-+ [ --disable-[$1] disable [$2]],
-+ [ --enable-[$1] enable [$2]]),
-+ [ if test "$enableval" = yes; then
-+ AC_MSG_RESULT(yes)
-+ ifelse($4, , , AC_DEFINE($4))
-+ else
-+ AC_MSG_RESULT(no)
-+ ifelse($5, , , AC_DEFINE($5))
-+ fi ],
-+ ifelse($3, on,
-+ [ AC_MSG_RESULT(yes)
-+ ifelse($4, , , AC_DEFINE($4)) ],
-+ [ AC_MSG_RESULT(no)
-+ ifelse($5, , , AC_DEFINE($5))]))])
-+
diff --git a/meta/recipes-devtools/openjade/openjade-1.3.2/makefile.patch b/meta/recipes-devtools/openjade/openjade-1.3.2/makefile.patch
index ac5c7447f6..84e1d63151 100644
--- a/meta/recipes-devtools/openjade/openjade-1.3.2/makefile.patch
+++ b/meta/recipes-devtools/openjade/openjade-1.3.2/makefile.patch
@@ -1,4 +1,5 @@
-Patch obtained from OpenEmbedded.
+This patch fixes libtool QA issues with WORKDIR creeping in to
+libospgrove.la and libostyle.la. Patch obtained from OpenEmbedded.
Signed-off-by: Scott Garman <scott.a.garman@intel.com>
Index: openjade-1.3.2/spgrove/Makefile.sub
diff --git a/meta/recipes-devtools/openjade/openjade-1.3.2/oj-native-libosp-fix.patch b/meta/recipes-devtools/openjade/openjade-1.3.2/oj-native-libosp-fix.patch
deleted file mode 100644
index 48e38048ba..0000000000
--- a/meta/recipes-devtools/openjade/openjade-1.3.2/oj-native-libosp-fix.patch
+++ /dev/null
@@ -1,15 +0,0 @@
-Patch obtained from OpenEmbedded.
-
-Signed-off-by: Scott Garman <scott.a.garman@intel.com>
-Index: openjade-1.3.2/Makefile.prog.in
-===================================================================
---- openjade-1.3.2.orig/Makefile.prog.in 2007-12-21 14:48:00.000000000 +0100
-+++ openjade-1.3.2/Makefile.prog.in 2007-12-21 14:50:12.000000000 +0100
-@@ -13,6 +13,7 @@
- ALL_LIBS = $(XLIBS) $(LIBS)
- Makefile.lt:
- echo 'LT_LIBS='`echo $(ALL_LIBS)|sed 's/\.a/.la/g'` >Makefile.lt
-+ sed -i -e "s|libosp.la|libosp.so|" Makefile.lt
-
- PROG:=$(shell echo "$(PROG)" | sed '@program_transform_name@')
-
diff --git a/meta/recipes-devtools/openjade/openjade_1.3.2.bb b/meta/recipes-devtools/openjade/openjade-native_1.3.2.bb
index f2ad8aef7c..f267fc5483 100644
--- a/meta/recipes-devtools/openjade/openjade_1.3.2.bb
+++ b/meta/recipes-devtools/openjade/openjade-native_1.3.2.bb
@@ -9,38 +9,26 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=641ff1e4511f0a87044ad42f87cb1045"
PR = "r0"
-DEPENDS = "opensp"
+DEPENDS = "opensp-native sgml-common-native"
RDEPENDS_${PN} = "sgml-common"
SRC_URI = "${SOURCEFORGE_MIRROR}/openjade/openjade-${PV}.tar.gz \
- file://configure.patch \
- file://autoconf.patch \
- file://makefile.patch \
- "
+ file://makefile.patch"
SRC_URI[md5sum] = "7df692e3186109cc00db6825b777201e"
SRC_URI[sha256sum] = "1d2d7996cc94f9b87d0c51cf0e028070ac177c4123ecbfd7ac1cb8d0b7d322d1"
-SRC_URI_append_virtclass-native = " file://oj-native-libosp-fix.patch"
-
-inherit autotools
+inherit autotools native
EXTRA_OECONF = "--enable-spincludedir=${STAGING_INCDIR}/OpenSP \
--enable-splibdir=${STAGING_LIBDIR}"
-acpaths = "-I ${S}/config"
-
-# Trailing whitespace is important. Otherwise compiler arguments will be messed
-# up, resulting in a fail in do_configure.
-CFLAGS_prepend = "-I${S}/include "
+CFLAGS =+ "-I${S}/include"
-do_configure_append () {
- cp config/configure.in .
-}
-
-do_install_append () {
+do_install() {
# Refer to http://www.linuxfromscratch.org/blfs/view/stable/pst/openjade.html
# for details.
+ install -d ${D}${bindir}
install -m 0755 ${S}/jade/.libs/openjade ${D}${bindir}/openjade
ln -sf openjade ${D}${bindir}/jade
@@ -62,5 +50,3 @@ do_install_append () {
install-catalog --add ${sysconfdir}/sgml/sgml-docbook.cat \
${sysconfdir}/sgml/openjade-${PV}.cat
}
-
-BBCLASSEXTEND = "native"