aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/openjade/openjade-native_1.3.2.bb
diff options
context:
space:
mode:
authorRichard Purdie <richard.purdie@linuxfoundation.org>2012-06-12 13:05:09 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-06-12 16:33:59 +0100
commit6f0d830ed047f700702645d454054dfd6fea6f25 (patch)
treeb84f15c83ccc0f90203ef0f74e3cf45484f6fcb4 /meta/recipes-devtools/openjade/openjade-native_1.3.2.bb
parentfe417e8a4d625c6933de72163d2fee52ac47f571 (diff)
downloadopenembedded-core-contrib-6f0d830ed047f700702645d454054dfd6fea6f25.tar.gz
openjade-native: Ensure we reautoconf the package
Currently since configure.in in is in a subdirectory, we don't reautoconf the recipe. We really need to do this, to update things like the libtool script used and fix various issues such as those that could creep in if a reautoconf is triggered for some reason. Since this source only calls AM_INIT_AUTOMAKE to gain the PACKAGE and VERSION definitions and that macro now errors if Makefile.am doesn't exist, we need to add these definitions manually. These changes avoid failures like: ---- | ... | DssslApp.cxx:117:36: error: 'PACKAGE' was not declared in this scope | DssslApp.cxx:118:36: error: 'VERSION' was not declared in this scope | make[2]: *** [DssslApp.lo] Error 1 ---- Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/openjade/openjade-native_1.3.2.bb')
-rw-r--r--meta/recipes-devtools/openjade/openjade-native_1.3.2.bb5
1 files changed, 5 insertions, 0 deletions
diff --git a/meta/recipes-devtools/openjade/openjade-native_1.3.2.bb b/meta/recipes-devtools/openjade/openjade-native_1.3.2.bb
index 18d311e9d5..5b29c1fda0 100644
--- a/meta/recipes-devtools/openjade/openjade-native_1.3.2.bb
+++ b/meta/recipes-devtools/openjade/openjade-native_1.3.2.bb
@@ -14,6 +14,7 @@ RDEPENDS_${PN} = "sgml-common-native"
SRC_URI = "${SOURCEFORGE_MIRROR}/openjade/openjade-${PV}.tar.gz \
file://makefile.patch \
+ file://reautoconf.patch \
file://user-declared-default-constructor.patch"
SRC_URI[md5sum] = "7df692e3186109cc00db6825b777201e"
@@ -38,6 +39,10 @@ CFLAGS =+ "-I${S}/include"
SSTATEPOSTINSTFUNCS += "openjade_sstate_postinst"
SYSROOT_PREPROCESS_FUNCS += "openjade_sysroot_preprocess"
+# configure.in needs to be reloacted to trigger reautoconf
+do_configure_prepend () {
+ cp ${S}/config/configure.in ${S}/
+}
# We need to do this else the source interdependencies aren't generated and
# build failures can result (e.g. zero size style/Makefile.dep file)