summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/ninja/ninja_1.8.2.bb
diff options
context:
space:
mode:
authorAlejandro Enedino Hernandez Samaniego <alejandr@xilinx.com>2018-01-19 16:19:06 -0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2018-02-06 10:54:40 +0000
commitf683b892b70a9587d9c2812ffc22da2375b34923 (patch)
tree633a04b67bf1528b186a2613df3d2538764848bd /meta/recipes-devtools/ninja/ninja_1.8.2.bb
parentdece983e35721ca1cfc6ddddaf52726fb1d6db1f (diff)
downloadopenembedded-core-contrib-f683b892b70a9587d9c2812ffc22da2375b34923.tar.gz
ninja: Upgrade from 1.7.2 to major release 1.8.2
Signed-off-by: Alejandro Enedino Hernandez Samaniego <alejandr@xilinx.com> Signed-off-by: Ross Burton <ross.burton@intel.com>
Diffstat (limited to 'meta/recipes-devtools/ninja/ninja_1.8.2.bb')
-rw-r--r--meta/recipes-devtools/ninja/ninja_1.8.2.bb30
1 files changed, 30 insertions, 0 deletions
diff --git a/meta/recipes-devtools/ninja/ninja_1.8.2.bb b/meta/recipes-devtools/ninja/ninja_1.8.2.bb
new file mode 100644
index 0000000000..c6fcfef3dd
--- /dev/null
+++ b/meta/recipes-devtools/ninja/ninja_1.8.2.bb
@@ -0,0 +1,30 @@
+SUMMARY = "Ninja is a small build system with a focus on speed."
+HOMEPAGE = "http://martine.github.com/ninja/"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://COPYING;md5=a81586a64ad4e476c791cda7e2f2c52e"
+
+DEPENDS = "re2c-native ninja-native"
+
+SRCREV = "253e94c1fa511704baeb61cf69995bbf09ba435e"
+
+SRC_URI = "git://github.com/ninja-build/ninja.git;branch=release"
+UPSTREAM_CHECK_GITTAGREGEX = "v(?P<pver>.*)"
+
+S = "${WORKDIR}/git"
+
+do_configure[noexec] = "1"
+
+do_compile_class-native() {
+ ./configure.py --bootstrap
+}
+
+do_compile() {
+ ./configure.py
+ ninja
+}
+
+do_install() {
+ install -D -m 0755 ${S}/ninja ${D}${bindir}/ninja
+}
+
+BBCLASSEXTEND = "native nativesdk"