aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/nasm/nasm_2.13.01.bb
diff options
context:
space:
mode:
authorRichard Purdie <richard.purdie@linuxfoundation.org>2017-05-26 19:00:36 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2017-05-29 15:15:13 +0100
commit265602c5355c71e31bb6d84e0e608dc86980853b (patch)
treeaef72928c706971909b196115a95d3622cf5ae0a /meta/recipes-devtools/nasm/nasm_2.13.01.bb
parenta256addb330ec7b781c381894cc72cbd4a5005dd (diff)
downloadopenembedded-core-contrib-265602c5355c71e31bb6d84e0e608dc86980853b.tar.gz
nasm: Upgrade 2.12.02 -> 2.13.01
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/nasm/nasm_2.13.01.bb')
-rw-r--r--meta/recipes-devtools/nasm/nasm_2.13.01.bb28
1 files changed, 28 insertions, 0 deletions
diff --git a/meta/recipes-devtools/nasm/nasm_2.13.01.bb b/meta/recipes-devtools/nasm/nasm_2.13.01.bb
new file mode 100644
index 0000000000..bf18cd6d14
--- /dev/null
+++ b/meta/recipes-devtools/nasm/nasm_2.13.01.bb
@@ -0,0 +1,28 @@
+SUMMARY = "General-purpose x86 assembler"
+SECTION = "devel"
+LICENSE = "BSD-2-Clause"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=90904486f8fbf1861cf42752e1a39efe"
+
+SRC_URI = "http://www.nasm.us/pub/nasm/releasebuilds/${PV}/nasm-${PV}.tar.bz2 "
+
+SRC_URI[md5sum] = "1f7d4662040d24351df7d6719ed4f97a"
+SRC_URI[sha256sum] = "08f97baf0a7f892128c6413cfa93b69dc5825fbbd06c70928aea028835d198fa"
+
+inherit autotools-brokensep
+
+do_configure_prepend () {
+ if [ -f ${S}/aclocal.m4 ] && [ ! -f ${S}/acinclude.m4 ]; then
+ mv ${S}/aclocal.m4 ${S}/acinclude.m4
+ fi
+}
+
+do_install() {
+ install -d ${D}${bindir}
+ install -d ${D}${mandir}/man1
+
+ oe_runmake 'INSTALLROOT=${D}' install
+}
+
+BBCLASSEXTEND = "native"
+
+DEPENDS = "groff-native"