aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/nasm/nasm_2.11.bb
diff options
context:
space:
mode:
authorLaurentiu Palcu <laurentiu.palcu@intel.com>2014-02-06 17:29:20 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2014-02-09 09:42:52 +0000
commitfa0c09168d715c05a80cfa0d926eaf1ad5a43d88 (patch)
tree9e6c46d33d73ed2470369a9e35503daf4461f9b2 /meta/recipes-devtools/nasm/nasm_2.11.bb
parent9203c879b333e7b1c390f43389cb917ae065185e (diff)
downloadopenembedded-core-contrib-fa0c09168d715c05a80cfa0d926eaf1ad5a43d88.tar.gz
nasm: upgrade to 2.11
(From OE-Core rev: 5847c2eb3fb03ce6de0842f69ae0c1d44ef3c8a0) Signed-off-by: Laurentiu Palcu <laurentiu.palcu@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/nasm/nasm_2.11.bb')
-rw-r--r--meta/recipes-devtools/nasm/nasm_2.11.bb29
1 files changed, 29 insertions, 0 deletions
diff --git a/meta/recipes-devtools/nasm/nasm_2.11.bb b/meta/recipes-devtools/nasm/nasm_2.11.bb
new file mode 100644
index 0000000000..859cd2188f
--- /dev/null
+++ b/meta/recipes-devtools/nasm/nasm_2.11.bb
@@ -0,0 +1,29 @@
+SUMMARY = "General-purpose x86 assembler"
+SECTION = "devel"
+LICENSE = "BSD-2-Clause"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=90904486f8fbf1861cf42752e1a39efe"
+COMPATIBLE_HOST = '(x86_64|i.86).*-(linux|freebsd.*)'
+
+
+SRC_URI = "http://www.nasm.us/pub/nasm/releasebuilds/${PV}/nasm-${PV}.tar.bz2 "
+SRC_URI[md5sum] = "4cd558047ea5ed51fc2c7c94e249c7b8"
+SRC_URI[sha256sum] = "1ce7e897c67255a195367a60c739a90a0b33a4a73f058f7cda3253bcf975642b"
+
+inherit autotools
+
+do_configure_prepend () {
+ if [ -f ${S}/aclocal.m4 ] && [ ! -f ${S}/acinclude.m4 ]; then
+ mv ${S}/aclocal.m4 ${S}/acinclude.m4
+ fi
+}
+
+do_install() {
+ install -d ${D}${bindir}
+ install -d ${D}${mandir}/man1
+
+ oe_runmake 'INSTALLROOT=${D}' install
+}
+
+BBCLASSEXTEND = "native"
+
+DEPENDS = "groff-native"