summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/nasm/nasm_2.10.09.bb
diff options
context:
space:
mode:
authorLaurentiu Palcu <laurentiu.palcu@intel.com>2013-07-30 11:40:16 +0300
committerSaul Wold <sgw@linux.intel.com>2013-08-01 21:57:54 -0700
commitef79df58e715c411db7726713c46b4504bba4a8e (patch)
treed8efa2e2b20c5330ea326bccaaa107240bfb9bef /meta/recipes-devtools/nasm/nasm_2.10.09.bb
parent7398e4f1141e14903d4eaabb922822a35c07c037 (diff)
downloadopenembedded-core-contrib-ef79df58e715c411db7726713c46b4504bba4a8e.tar.gz
nasm: upgrade to 2.10.09
Signed-off-by: Laurentiu Palcu <laurentiu.palcu@intel.com> Signed-off-by: Saul Wold <sgw@linux.intel.com>
Diffstat (limited to 'meta/recipes-devtools/nasm/nasm_2.10.09.bb')
-rw-r--r--meta/recipes-devtools/nasm/nasm_2.10.09.bb29
1 files changed, 29 insertions, 0 deletions
diff --git a/meta/recipes-devtools/nasm/nasm_2.10.09.bb b/meta/recipes-devtools/nasm/nasm_2.10.09.bb
new file mode 100644
index 0000000000..19663d6be7
--- /dev/null
+++ b/meta/recipes-devtools/nasm/nasm_2.10.09.bb
@@ -0,0 +1,29 @@
+DESCRIPTION = "General-purpose x86 assembler"
+SECTION = "devel"
+LICENSE = "BSD-2-Clause"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=90904486f8fbf1861cf42752e1a39efe"
+COMPATIBLE_HOST = '(x86_64|i.86).*-(linux|freebsd.*)'
+
+
+SRC_URI = "http://www.nasm.us/pub/nasm/releasebuilds/${PV}/nasm-${PV}.tar.bz2 "
+SRC_URI[md5sum] = "0e45ca0d3d7ff36d503777eaa673e2ae"
+SRC_URI[sha256sum] = "7141180d3874b5967c6a60191e8d45fba9cc86bd60a4803ad80b6b6b3eac36b9"
+
+inherit autotools
+
+do_configure_prepend () {
+ if [ -f ${S}/aclocal.m4 ] && [ ! -f ${S}/acinclude.m4 ]; then
+ mv ${S}/aclocal.m4 ${S}/acinclude.m4
+ fi
+}
+
+do_install() {
+ install -d ${D}${bindir}
+ install -d ${D}${mandir}/man1
+
+ oe_runmake 'INSTALLROOT=${D}' install
+}
+
+BBCLASSEXTEND = "native"
+
+DEPENDS = "groff-native"