aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/mtools/mtools
diff options
context:
space:
mode:
authorWenlin Kang <wenlin.kang@windriver.com>2014-10-16 06:26:49 -0400
committerRichard Purdie <richard.purdie@linuxfoundation.org>2014-10-18 16:12:56 +0200
commit7308da9ccd4b8b9b5077aacd0442be28a6c73c61 (patch)
tree53a4738f530924354ec27b95fb0f033a4becd603 /meta/recipes-devtools/mtools/mtools
parente1c77392143e538a2305f63ee3add611ec66e877 (diff)
downloadopenembedded-core-contrib-7308da9ccd4b8b9b5077aacd0442be28a6c73c61.tar.gz
mtools: fix broken /usr/bin/lz
When build fs with mtools-3.9.9, has file /usr/bin/lz in rootfs, it is the symlink to uz: root@qemu3:~# /usr/bin/lz -sh: /usr/bin/lz: No such file or directory $root@qemu3:~# ls -l /usr/bin/lz lrwxrwxrwx 1 root root 2 Jul 18 18:07 /usr/bin/lz -> uz root@qemu3:~# uz -sh: uz: command not found But the uz isn't actually exist, so the result is that lz is a broken symlink. The root cause is that uz hasn't been installed when install-scripts. Signed-off-by: Wenlin Kang <wenlin.kang@windriver.com> Signed-off-by: Jackie Huang <jackie.huang@windriver.com>
Diffstat (limited to 'meta/recipes-devtools/mtools/mtools')
-rw-r--r--meta/recipes-devtools/mtools/mtools/fix-broken-lz.patch23
1 files changed, 23 insertions, 0 deletions
diff --git a/meta/recipes-devtools/mtools/mtools/fix-broken-lz.patch b/meta/recipes-devtools/mtools/mtools/fix-broken-lz.patch
new file mode 100644
index 0000000000..cb454917ff
--- /dev/null
+++ b/meta/recipes-devtools/mtools/mtools/fix-broken-lz.patch
@@ -0,0 +1,23 @@
+Upstream-Status: Backport
+
+Signed-off-by: Wenlin Kang <wenlin.kang@windriver.com>
+Signed-off-by: Jackie Huang <jackie.huang@windriver.com>
+---
+ Makefile.in | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/Makefile.in b/Makefile.in
+index 8f9305a..694e837 100644
+--- a/Makefile.in
++++ b/Makefile.in
+@@ -251,6 +251,7 @@ install-scripts: ${DESTDIR}$(bindir)/mtools
+ @$(top_srcdir)/mkinstalldirs ${DESTDIR}$(bindir)
+ @for j in $(SCRIPTS) ; do \
+ $(INSTALL_SCRIPT) $(srcdir)/scripts/$$j ${DESTDIR}$(bindir)/$$j ; \
++ $(INSTALL_PROGRAM) $(srcdir)/scripts/$$j ${DESTDIR}$(bindir)/$$j ; \
+ echo ${DESTDIR}$(bindir)/$$j ; \
+ done
+ rm -f ${DESTDIR}$(bindir)/lz
+--
+2.0.0
+