aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/meson
diff options
context:
space:
mode:
authorAlexander Kanavin <alexander.kanavin@linux.intel.com>2018-04-04 14:13:16 +0300
committerRichard Purdie <richard.purdie@linuxfoundation.org>2018-05-04 09:54:52 +0100
commit8b7e013da561838629a9f93d53dbf4d4415ee856 (patch)
tree5d6cdab8ce8d984ea2356b57e8dce6755c380635 /meta/recipes-devtools/meson
parenta3d27ff5763d331c4d6c8b815af5624103311544 (diff)
downloadopenembedded-core-contrib-8b7e013da561838629a9f93d53dbf4d4415ee856.tar.gz
meson: update to 0.45.1
Signed-off-by: Alexander Kanavin <alexander.kanavin@linux.intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/meson')
-rw-r--r--meta/recipes-devtools/meson/meson/0001-gtkdoc-fix-issues-that-arise-when-cross-compiling.patch34
-rw-r--r--meta/recipes-devtools/meson/meson_0.45.1.bb (renamed from meta/recipes-devtools/meson/meson_0.44.1.bb)4
2 files changed, 18 insertions, 20 deletions
diff --git a/meta/recipes-devtools/meson/meson/0001-gtkdoc-fix-issues-that-arise-when-cross-compiling.patch b/meta/recipes-devtools/meson/meson/0001-gtkdoc-fix-issues-that-arise-when-cross-compiling.patch
index 1912e94358..a00743fda8 100644
--- a/meta/recipes-devtools/meson/meson/0001-gtkdoc-fix-issues-that-arise-when-cross-compiling.patch
+++ b/meta/recipes-devtools/meson/meson/0001-gtkdoc-fix-issues-that-arise-when-cross-compiling.patch
@@ -1,7 +1,7 @@
-From c5692cac9c555664281377a82bf8b1e46934f437 Mon Sep 17 00:00:00 2001
+From d1c2b3bf01f1a5897cf5c906ba2326fb68c6af12 Mon Sep 17 00:00:00 2001
From: Alexander Kanavin <alex.kanavin@gmail.com>
Date: Fri, 4 Aug 2017 16:16:41 +0300
-Subject: [PATCH 1/3] gtkdoc: fix issues that arise when cross-compiling
+Subject: [PATCH] gtkdoc: fix issues that arise when cross-compiling
Specifically:
1) Make it possible to specify a wrapper for executing binaries
@@ -21,10 +21,10 @@ Signed-off-by: Alexander Kanavin <alex.kanavin@gmail.com>
2 files changed, 22 insertions(+), 5 deletions(-)
diff --git a/mesonbuild/modules/gnome.py b/mesonbuild/modules/gnome.py
-index 56765a5..4f7fe30 100644
+index 569011e..770ff4f 100644
--- a/mesonbuild/modules/gnome.py
+++ b/mesonbuild/modules/gnome.py
-@@ -769,6 +769,10 @@ This will become a hard error in the future.''')
+@@ -773,6 +773,10 @@ This will become a hard error in the future.''')
'--mode=' + mode]
if namespace:
args.append('--namespace=' + namespace)
@@ -35,10 +35,10 @@ index 56765a5..4f7fe30 100644
args += self._unpack_args('--htmlargs=', 'html_args', kwargs)
args += self._unpack_args('--scanargs=', 'scan_args', kwargs)
args += self._unpack_args('--scanobjsargs=', 'scanobjs_args', kwargs)
-@@ -796,14 +800,22 @@ This will become a hard error in the future.''')
- raise MesonException(
- 'Gir include dirs should be include_directories().')
+@@ -829,14 +833,22 @@ This will become a hard error in the future.''')
cflags.update(get_include_args(inc_dirs))
+ cflags.update(state.environment.coredata.external_args['c'])
+ ldflags.update(state.environment.coredata.external_link_args['c'])
+
+ cross_c_args = " ".join(state.environment.cross_info.config["properties"].get('c_args', ""))
+ cross_link_args = " ".join(state.environment.cross_info.config["properties"].get('c_link_args', ""))
@@ -62,26 +62,27 @@ index 56765a5..4f7fe30 100644
return args
diff --git a/mesonbuild/scripts/gtkdochelper.py b/mesonbuild/scripts/gtkdochelper.py
-index 4406b28..b846827 100644
+index 2a5ee8b..2fd692b 100644
--- a/mesonbuild/scripts/gtkdochelper.py
+++ b/mesonbuild/scripts/gtkdochelper.py
-@@ -44,13 +44,14 @@ parser.add_argument('--ignore-headers', dest='ignore_headers', default='')
+@@ -45,6 +45,7 @@ parser.add_argument('--ignore-headers', dest='ignore_headers', default='')
parser.add_argument('--namespace', dest='namespace', default='')
parser.add_argument('--mode', dest='mode', default='')
parser.add_argument('--installdir', dest='install_dir')
+parser.add_argument('--gtkdoc-exe-wrapper', dest='gtkdoc_exe_wrapper')
- def gtkdoc_run_check(cmd, cwd):
- # Put stderr into stdout since we want to print it out anyway.
+ def gtkdoc_run_check(cmd, cwd, library_path=None):
+ env = dict(os.environ)
+@@ -54,7 +55,7 @@ def gtkdoc_run_check(cmd, cwd, library_path=None):
# This preserves the order of messages.
- p, out = Popen_safe(cmd, cwd=cwd, stderr=subprocess.STDOUT)[0:2]
+ p, out = Popen_safe(cmd, cwd=cwd, env=env, stderr=subprocess.STDOUT)[0:2]
if p.returncode != 0:
- err_msg = ["{!r} failed with status {:d}".format(cmd[0], p.returncode)]
+ err_msg = ["{!r} failed with status {:d}".format(cmd, p.returncode)]
if out:
err_msg.append(out)
raise MesonException('\n'.join(err_msg))
-@@ -58,7 +59,7 @@ def gtkdoc_run_check(cmd, cwd):
+@@ -62,7 +63,7 @@ def gtkdoc_run_check(cmd, cwd, library_path=None):
def build_gtkdoc(source_root, build_root, doc_subdir, src_subdirs,
main_file, module,
html_args, scan_args, fixxref_args, mkdb_args,
@@ -90,7 +91,7 @@ index 4406b28..b846827 100644
html_assets, content_files, ignore_headers, namespace,
expand_content_files, mode):
print("Building documentation for %s" % module)
-@@ -111,6 +112,9 @@ def build_gtkdoc(source_root, build_root, doc_subdir, src_subdirs,
+@@ -115,6 +116,9 @@ def build_gtkdoc(source_root, build_root, doc_subdir, src_subdirs,
if gobject_typesfile:
scanobjs_cmd = ['gtkdoc-scangobj'] + scanobjs_args + ['--types=' + gobject_typesfile,
'--module=' + module,
@@ -100,7 +101,7 @@ index 4406b28..b846827 100644
'--cflags=' + cflags,
'--ldflags=' + ldflags,
'--ld=' + ld]
-@@ -207,6 +211,7 @@ def run(args):
+@@ -219,6 +223,7 @@ def run(args):
mkdbargs,
options.gobject_typesfile,
scanobjsargs,
@@ -108,6 +109,3 @@ index 4406b28..b846827 100644
options.ld,
options.cc,
options.ldflags,
---
-2.15.0
-
diff --git a/meta/recipes-devtools/meson/meson_0.44.1.bb b/meta/recipes-devtools/meson/meson_0.45.1.bb
index 6a81dab265..9decdd0c24 100644
--- a/meta/recipes-devtools/meson/meson_0.44.1.bb
+++ b/meta/recipes-devtools/meson/meson_0.45.1.bb
@@ -10,8 +10,8 @@ SRC_URI = "https://github.com/mesonbuild/meson/releases/download/${PV}/${BP}.tar
file://0001-Linker-rules-move-cross_args-in-front-of-output_args.patch \
file://0003-native_bindir.patch \
"
-SRC_URI[md5sum] = "82b1198bf714b5a4da84bfe8376c79cc"
-SRC_URI[sha256sum] = "2ea1a721574adb23160b6481191bcc1173f374e02b0ff3bb0ae85d988d97e4fa"
+SRC_URI[md5sum] = "4d9c7b3a7365b7b472f00af14e034949"
+SRC_URI[sha256sum] = "4d0bb0dbb1bb556cb7a4092fdfea3d6e76606bd739a4bc97481c2d7bc6200afb"
UPSTREAM_CHECK_URI = "https://github.com/mesonbuild/meson/releases"
inherit setuptools3