summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/lua
diff options
context:
space:
mode:
authorAlexander Kanavin <alex.kanavin@gmail.com>2022-02-02 19:27:42 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2022-02-05 17:22:14 +0000
commit734cdfddd2d2a0a0e3be2b577bd4175a2abd73e5 (patch)
tree361fb01e9952b62013f89c6a9d764f6718e3c0ed /meta/recipes-devtools/lua
parent01f476f56be9ac9a124e80125a5a25d523057466 (diff)
downloadopenembedded-core-contrib-734cdfddd2d2a0a0e3be2b577bd4175a2abd73e5.tar.gz
lua: upgrade 5.4.3 -> 5.4.4
Signed-off-by: Alexander Kanavin <alex.kanavin@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/lua')
-rw-r--r--meta/recipes-devtools/lua/lua/74d99057a5146755e737c479850f87fd0e3b6868.patch43
-rw-r--r--meta/recipes-devtools/lua/lua_5.4.4.bb (renamed from meta/recipes-devtools/lua/lua_5.4.3.bb)12
2 files changed, 3 insertions, 52 deletions
diff --git a/meta/recipes-devtools/lua/lua/74d99057a5146755e737c479850f87fd0e3b6868.patch b/meta/recipes-devtools/lua/lua/74d99057a5146755e737c479850f87fd0e3b6868.patch
deleted file mode 100644
index dcdc04837d..0000000000
--- a/meta/recipes-devtools/lua/lua/74d99057a5146755e737c479850f87fd0e3b6868.patch
+++ /dev/null
@@ -1,43 +0,0 @@
-From 74d99057a5146755e737c479850f87fd0e3b6868 Mon Sep 17 00:00:00 2001
-From: Roberto Ierusalimschy <roberto@inf.puc-rio.br>
-Date: Wed, 3 Nov 2021 15:04:18 -0300
-Subject: [PATCH] Bug: C stack overflow with coroutines
-
-'coroutine.resume' did not increment counter of C calls when
-continuing execution after a protected error (that is,
-while running 'precover').
----
- ldo.c | 6 ++++--
- testes/cstack.lua | 14 ++++++++++++++
- 2 files changed, 18 insertions(+), 2 deletions(-)
-
-Upstream-Status: Backport [https://github.com/lua/lua/commit/74d99057a5146755e737c479850f87fd0e3b6868.patch]
-CVE: CVE-2021-43519
-
-diff --git a/src/ldo.c b/src/ldo.c
-index d0edc8b4f..66f890364 100644
---- a/src/ldo.c
-+++ b/src/ldo.c
-@@ -759,11 +759,10 @@ static void resume (lua_State *L, void *ud) {
- StkId firstArg = L->top - n; /* first argument */
- CallInfo *ci = L->ci;
- if (L->status == LUA_OK) /* starting a coroutine? */
-- ccall(L, firstArg - 1, LUA_MULTRET, 1); /* just call its body */
-+ ccall(L, firstArg - 1, LUA_MULTRET, 0); /* just call its body */
- else { /* resuming from previous yield */
- lua_assert(L->status == LUA_YIELD);
- L->status = LUA_OK; /* mark that it is running (again) */
-- luaE_incCstack(L); /* control the C stack */
- if (isLua(ci)) { /* yielded inside a hook? */
- L->top = firstArg; /* discard arguments */
- luaV_execute(L, ci); /* just continue running Lua code */
-@@ -814,6 +813,9 @@ LUA_API int lua_resume (lua_State *L, lua_State *from, int nargs,
- else if (L->status != LUA_YIELD) /* ended with errors? */
- return resume_error(L, "cannot resume dead coroutine", nargs);
- L->nCcalls = (from) ? getCcalls(from) : 0;
-+ if (getCcalls(L) >= LUAI_MAXCCALLS)
-+ return resume_error(L, "C stack overflow", nargs);
-+ L->nCcalls++;
- luai_userstateresume(L, nargs);
- api_checknelems(L, (L->status == LUA_OK) ? nargs + 1 : nargs);
- status = luaD_rawrunprotected(L, resume, &nargs);
diff --git a/meta/recipes-devtools/lua/lua_5.4.3.bb b/meta/recipes-devtools/lua/lua_5.4.4.bb
index a204242bc0..f50328ecfd 100644
--- a/meta/recipes-devtools/lua/lua_5.4.3.bb
+++ b/meta/recipes-devtools/lua/lua_5.4.4.bb
@@ -7,19 +7,13 @@ HOMEPAGE = "http://www.lua.org/"
SRC_URI = "http://www.lua.org/ftp/lua-${PV}.tar.gz;name=tarballsrc \
file://lua.pc.in \
${@bb.utils.contains('DISTRO_FEATURES', 'ptest', 'http://www.lua.org/tests/lua-${PV_testsuites}-tests.tar.gz;name=tarballtest file://run-ptest ', '', d)} \
- file://74d99057a5146755e737c479850f87fd0e3b6868.patch \
"
# if no test suite matches PV release of Lua exactly, download the suite for the closest Lua release.
-PV_testsuites = "5.4.3"
+PV_testsuites = "5.4.4"
-SRC_URI[tarballsrc.sha256sum] = "f8612276169e3bfcbcfb8f226195bfc6e466fe13042f1076cbde92b7ec96bbfb"
-SRC_URI[tarballtest.sha256sum] = "5d29c3022897a8290f280ebe1c6853248dfa35a668e1fc02ba9c8cde4e7bf110"
-
-# remove at next version upgrade or when output changes
-# was added after intermittent repro failures poisoned the cache
-PR = "r1"
-HASHEQUIV_HASH_VERSION .= ".2"
+SRC_URI[tarballsrc.sha256sum] = "164c7849653b80ae67bec4b7473b884bf5cc8d2dca05653475ec2ed27b9ebf61"
+SRC_URI[tarballtest.sha256sum] = "04d28355cd67a2299dfe5708b55a0ff221ccb1a3907a3113cc103ccc05ac6aad"
inherit pkgconfig binconfig ptest