summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/llvm/llvm_git.bb
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2018-08-20 11:59:51 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2018-08-21 14:49:42 +0100
commit959fcc81295cc7077824266d1af9e90aaff803bc (patch)
tree6e2b595f9d5e9bbbd0c29db893467748a13ad034 /meta/recipes-devtools/llvm/llvm_git.bb
parentde1ba75423afb112cbf3272fd778601352e1149d (diff)
downloadopenembedded-core-contrib-959fcc81295cc7077824266d1af9e90aaff803bc.tar.gz
llvm: Use HOST_ARCH in LLVM_TARGETS_TO_BUILD for builds
LLVM_TARGETS_TO_BUILD is needed to represent HOST_ARCH for builds and target specific additions should use class-target override (From OE-Core rev: 5e6e08512e130951e66376ea43e4e6a98941b950) Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/llvm/llvm_git.bb')
-rw-r--r--meta/recipes-devtools/llvm/llvm_git.bb11
1 files changed, 6 insertions, 5 deletions
diff --git a/meta/recipes-devtools/llvm/llvm_git.bb b/meta/recipes-devtools/llvm/llvm_git.bb
index d853d4151d..df7c1dddd3 100644
--- a/meta/recipes-devtools/llvm/llvm_git.bb
+++ b/meta/recipes-devtools/llvm/llvm_git.bb
@@ -44,14 +44,15 @@ def get_llvm_arch(bb, d, arch_var):
else:
raise bb.parse.SkipRecipe("Cannot map '%s' to a supported LLVM architecture" % a)
-def get_llvm_target_arch(bb, d):
- return get_llvm_arch(bb, d, 'TARGET_ARCH')
+def get_llvm_host_arch(bb, d):
+ return get_llvm_arch(bb, d, 'HOST_ARCH')
+
#
# Default to build all OE-Core supported target arches (user overridable).
#
-LLVM_TARGETS ?= "${@get_llvm_target_arch(bb, d)}"
-LLVM_TARGETS_prepend_x86 = "AMDGPU;"
-LLVM_TARGETS_prepend_x86-64 = "AMDGPU;"
+LLVM_TARGETS ?= "${@get_llvm_host_arch(bb, d)}"
+LLVM_TARGETS_prepend_class-target_x86 = "AMDGPU;"
+LLVM_TARGETS_prepend_class-target_x86-64 = "AMDGPU;"
ARM_INSTRUCTION_SET_armv5 = "arm"
ARM_INSTRUCTION_SET_armv4t = "arm"